Unnecessary separator at bottom of help menu on Mac following move of check for updates to Thunderbird menu

VERIFIED FIXED in Thunderbird 3.3a1

Status

Thunderbird
General
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: standard8, Assigned: standard8)

Tracking

unspecified
Thunderbird 3.3a1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
Created attachment 479724 [details] [diff] [review]
The fix

mozilla-central has moved the "Check For Updates" option to the application menu.

On Thunderbird, this has left an unnecessary separator.

The attached patch fixes that by renaming our help menu separators to match those that the core code expects, so they can be hidden when necessary.
Attachment #479724 - Flags: review?(bwinton)
(Assignee)

Updated

7 years ago
Assignee: nobody → bugzilla
Duplicate of this bug: 596701
Comment on attachment 479724 [details] [diff] [review]
The fix

I actually have that very same patch in my queue, from Ludo's bug, but then I got tangled up trying to make Fx's state something worth emulating (they actually hide updateSeparator on every platform in every case, twice for Mac without the updater, and have a different one that's actually visible).
Attachment #479724 - Flags: review?(bwinton) → review+
(Assignee)

Comment 3

7 years ago
Checked in: http://hg.mozilla.org/comm-central/rev/b7715ae465c6
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.3a1
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0b7pre) Gecko/20101002 Thunderbird/3.3a1pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.