Visit the url that user entered without searing

RESOLVED WONTFIX

Status

Firefox for Android Graveyard
General
RESOLVED WONTFIX
8 years ago
8 years ago

People

(Reporter: Halton Huo, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET CLR 1.1.4322; InfoPath.2; OfficeLiveConnector.1.3; OfficeLivePatch.0.0; MS-RTC LM 8)
Build Identifier: 

After patch for bug #591490 get push in http://hg.mozilla.org/mobile-browser/rev/a1cb7922b8b7.

The go button is replaced by a search button, which offer better url compeletion I think. But not for all the cases. 
1. When user does not have internet access to google, wikipedia, amazon, twitter.
2. When user want to access local files with file:///

My suggestion is adding a new context-command like "No searching" when user click the search button(Or press Enter)

Comments?

Reproducible: Always
To go to the URL without searching, you can press the Enter/Return button on the keyboard.  Since screen space is limited on mobile, we decided not to duplicate this functionality with an on-screen button.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.