Clicking "resend the confirmation message" link generates a "we can't find what you're looking for" message (page not found)


Status Graveyard
8 years ago
2 years ago


(Reporter: James, Assigned: clouserw)


Windows Vista


(Whiteboard: [qa-later], URL)



8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv: Gecko/20100914 Firefox/3.6.10 (.NET CLR 3.5.30729)
Build Identifier: 

I created an account for to use the new collections feature. I don't believe I got the original verification email, so after cleaning out spam folder I wanted to try getting a new confirmation message to verify my account.

When I try to sign in, I get a "Please confirm your user account first with the code you received by email." message, with a link to "resend the confirmation message". When I click on this link, I get a page that says:

We're sorry, but we can't find what you're looking for.

The page or file you requested wasn't found on our site. It's possible that you clicked a link that's out of date, or typed in the address incorrectly. 

Reproducible: Always

Steps to Reproduce:
1. Created an account for
2. Try to log in before it is verified/confirmed
3. Click link to "resend the confirmation message"
Actual Results:  
Error page (essentially a 404-type message)

Expected Results:  
Page saying a new email was sent to my address and thanks for playing.

Comment 1

8 years ago
This can happen if the user id is unrecognized.  What was the URL it was sending you to?

Comment 2

8 years ago

Can it know my username and password (having a "valid" account but not validated yet) but have an issue with my id?

If I give it a bogus password or username, it comes up with a different message, so it seems like the account is at least partially created.

Comment 3

8 years ago
That is a really old URL format - did you just get the email? is the actual URL I think, which I hit.  Did you get a new email?

Comment 4

8 years ago
Yes, just got two of them, actually. I clicked the link contained within the most recent of the two and it verified me.  Thank you very much for helping me verify my account.

The take-away seems to be that the link in the account creation process needs to updated to the new format and that will prevent others from having the same problem in the future.

Thanks again for your assistance.


Comment 5

8 years ago
Sure, thanks for the heads up.  The emails going out use the right URL as far as I can see, so I don't know where you got yours.  We'll keep an eye out though, thanks.
Assignee: nobody → clouserw
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 6

8 years ago
Just wanted to follow up and clarify that the link was not in an email, it was on the web page. 

1) create a new account, but do not confirm it
2) attempt to log into that new account on the website by going to:
3) Type in your username and password for the account you just created and submit the login form
3) You will get a message on the next web page that says in a red box "Please confirm your user account first with the code you received by email." Below this message there is some additional paragraphs that contains a link to "resend the confirmation message". This is the web page that contains the link is that is using the old format, leading to the "we can't find what you're looking for" message

Comment 7

8 years ago
Ah, I can reproduce that.  Thanks.
Ever confirmed: true
Resolution: FIXED → ---
Target Milestone: --- → 5.12.1

Comment 8

8 years ago
fixed in r75073, no schedule to go live yet.
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Depends on: 601717
(In reply to comment #8)
> fixed in r75073, no schedule to go live yet.

The link works but I'm taken to the Login page immediately after; is that expected behavior?  Shouldn't there be an interstitial page telling me the confirmation email was re-sent?

Comment 10

8 years ago
There is a message, but you don't see it because the login page is still on remora.
(In reply to comment #10)
> There is a message, but you don't see it because the login page is still on
> remora.

In that case, shouldn't this depend on the login page being in Zamboni (bug 560978), first?  The confirmation-message-sent page seems important to show.

Comment 12

8 years ago
Right now, we do show a meaningful message for users,after registration. Check

But till we move away from remora, we won't have the interstitial confirmation page.

I am adding the [qa-later] flags to the whiteboard,just as a reminder to go back and verify this when we move completely to zamboni.
Whiteboard: [qa-later]
Product: → Graveyard
You need to log in before you can comment on or make changes to this bug.