Setting initial state of dropdown element not working

VERIFIED DUPLICATE of bug 50376

Status

()

Core
Layout: Form Controls
P3
normal
VERIFIED DUPLICATE of bug 50376
18 years ago
8 years ago

People

(Reporter: mkaply, Assigned: rods (gone))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
Testcase attached.

On 4.X this testcase works.

You open the page and the current date is selected.

On Mozilla, no selection is made.

We debugged it, and it looks like the selection is being set and then reflow is 
resetting it.
(Reporter)

Comment 1

18 years ago
Created attachment 19228 [details] [diff] [review]
Testcase for dropdown selection

Comment 2

18 years ago
-> HTML Form Controls, for now, although this may be more a DOM0 issue. 
I'll attach a simpler testcase, which shows that :
(1) setting the window.onload in an inline script has a different effect from 
    setting it as an attribute of the <body>, and 
(2) if I reference the .selected property before I attempt to set it, then the  
   test case will work as intended.
Assignee: trudelle → rods
Component: XP Toolkit/Widgets → HTML Form Controls
QA Contact: jrgm → bsharma

Comment 3

18 years ago
Created attachment 19233 [details]
testcase, simplified from original
(Assignee)

Comment 4

18 years ago
This is basically the same bug as Bug 50376 - dupping

*** This bug has been marked as a duplicate of 50376 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

17 years ago
Verified dup
Status: RESOLVED → VERIFIED

Updated

8 years ago
Blocks: 600086

Updated

8 years ago
No longer blocks: 600086
You need to log in before you can comment on or make changes to this bug.