If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

can't reach iframe contents via css

RESOLVED INVALID

Status

Core Graveyard
Skinability
P3
normal
RESOLVED INVALID
17 years ago
9 years ago

People

(Reporter: Robert Kaiser, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
For my LCARStrek skin, I'm using padding: 3px on the <window> element. that does
what I want but gives me a border of 6px between e.g. Bookmarks sidebar and the
window border because inside the <iframe> where the sidebar panel lives in,
there is another window element of the bookmarks sidebar.

So I tried to set that padding to zarro for every window inside that panel iframe:
.iframe-panel window { border: 1px solid red; padding: 0px; }
(that border is only for debugging)
Mozilla doesn't apply those atrributes though.
I can't reach any element within that iframe, a good debugging case is
.iframe-panel tree { border: 1px solid red; }
for the bookmarks panel.

Should we be able to do this or would that be a bug itself?

I'm not sure, but it's a problem when skinning sidebar at least...
you can't do this. IFRAME document is a separate document, capable of loading
its own stylesheets.

not a bug.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.