Closed Bug 600954 Opened 9 years ago Closed 9 years ago

Error: uncaught exception: [object Object] in Error Console after going to www.google.com and when there's no sync information set

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 600815

People

(Reporter: nhirata, Unassigned)

Details

Attachments

(1 file)

Mozilla/5.0 (Maemo;Linux armv71; rv:2.0b7pre)Gecko/20100930 Firefox/4.0b7pre Fennec/4.0b2pre
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b7pre) Gecko/20100930 Firefox/4.0b7pre Fennec/4.0b2pre
1. turn on the error console
2. make sure Sync is cleared out
3. go to URL : http://www.google.com
4. go to error console

Expected: No errors
Actual : 
1. Engine.Tabs WARN Sync failed
2. Error: uncaught exception: [object Object]
Happens when there's no profile.
tracking-fennec: --- → ?
Summary: Error: uncaught exception: [object Object] in Error Console after going to www.google.com and then looking at the error console. → Error: uncaught exception: [object Object] in Error Console after going to www.google.com and when there's no sync information set
OS: Mac OS X → All
Hardware: x86 → All
Attached patch Check for weaveSplinter Review
I got this error when using the awesomebar without Sync set up. This fixes that. Not sure if its exactly what the bug describes, but if you're using the awesomebar to get to Google, it could be.
Attachment #480684 - Flags: review?(mark.finkle)
Comment on attachment 480684 [details] [diff] [review]
Check for weave

bug 600815 has some fixes for this error
Attachment #480684 - Flags: review?(mark.finkle)
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 600815
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.