Closed Bug 601049 Opened 10 years ago Closed 6 years ago

Add Credits link to its rightful place in the About Mozilla Firefox window

Categories

(Firefox :: General, defect)

4.0 Branch
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: gingerbread_man, Unassigned)

References

Details

(Keywords: ux-consistency, ux-discovery)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10
Build Identifier: Mozilla/5.0 (Windows NT 6.0; Win64; x64; rv:2.0b7pre) Gecko/20100929 Firefox/4.0b7pre

Rationale:
* Giving credit where credit is due is just common courtesy, and the least Mozilla can do for the people who worked on the software. A link labeled "global community" does not make one think "the people who contributed their time and effort to make this", and given the proximity to "Mozilla", it looks like further information about Mozilla Foundation/Corporation.
* According to bug 579547, comment 3 the original Credits button was removed because the list was not up-to-date. But this is being addressed by bug 594788
* The new About dialog is significantly wider and there is ample space to have four links at the bottom instead of three.

In a nutshell:
A Credits link belongs on the same row as Licensing Information, End User Rights and Privacy Policy.

Reproducible: Always
Depends on: 579547, 594788
Attached image 3.6.10 versus proposed
"global community" already goes to the credits page.
Version: unspecified → 4.0 Branch
This bug was reported using a pre-release version of Firefox 4. Now that Firefox 4.0.1 final has been released, can you please update and retest your bug? A fresh profile would be a good starting place to test, 
http://support.mozilla.com/kb/Managing+profiles. If you continue to see the issue, can you please update this bug with your results?

Filter: firefox4prebugsunco
Mozilla/5.0 (X11; Linux i686; rv:29.0) Gecko/20100101 Firefox/29.0 (20131223030203)

The current behavior is by design. The "global community" link leads to about:credits.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.