Closed Bug 601162 Opened 14 years ago Closed 14 years ago

statistics of blog от blogspot.com does not appear

Categories

(Core :: General, defect)

x86
Windows 7
defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: mdykun, Unassigned)

Details

(Keywords: qawanted)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b7pre) Gecko/20100930 Firefox/4.0b7pre
Build Identifier: 

When you go to see your statistics on http://draft.blogger.com/stats2.g?blogID=some_blog_ID, nothing happens, only shows the word "stats loading". On FF 3.6.10 stats loading correctly.

Reproducible: Always

Steps to Reproduce:
1. Login into google blogging system (blogger.com or blogspot.com
2. Go to http://draft.blogger.com/stats2.g?blogID=some_blog_ID

Actual Results:  
shows the word "stats loading" permanently
So reproducing this involves a blogger.com login, right?

Any errors in the JS console?
> So reproducing this involves a blogger.com login, right?
Yes.
> Any errors in the JS console?
Where can I see it?
Tools > Web Console, then load the page in question.
error:
20:31:01.297: Exception: uncaught exception: Class$xKb: Cannot find 'browserInfo' in Dictionary StatsDataDictionary
 keys found: [browserInfo, blockStatsPath] Исходный файл:  Строка: 0, Столбец: 0 Категория content javascript

sorry, info partially in russian, because locale is ru-ru
That's ok; I read Russian.  ;)

If you go into about:config, filter on "jit" and toggle off the methodjit, does that fix things?

Also, are you willing to save the page and scripts involved and attach them here?
Attached file page with scripts
> If you go into about:config, filter on "jit" and toggle off the methodjit, does
that fix things?
No, it does not fix trouble

>Also, are you willing to save the page and scripts involved and attach them
here?
ok, attached
I tried this, and I get that JS error in both Firefox 3.6 and current trunk, so it sounds like it's not related to the problem at hand....

I'll see if I can find someone with a blogger account to look into this, but otherwise would you be willing to try nightlies to narrow down when the problem appeared?
The problem appeared 5-7 nightlies ago. thnx anyway
> The problem appeared 5-7 nightlies ago.

Oh, ok.  If you're willing to hunt down the nightlies right before and after it appeared and paste their mercurial changeset IDs (the http URIs from about:buildconfig) here, that would be really helpful.
Ok, i'm trying to do this
maybe I was wrong. Stats does not appear at least a version of 3 September. Apparently the problem is deeper.
've tried on Google Chrome, Opera, Firefox 3.6 - everything is working correctly.
OK.  Are you willing to try older nightlies?
Yes, maybe tomorrow I will try them
In today's nightly stats works fine, finally
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: