[comm-central, Opt MacOSX] "jsfun.cpp:1148: error: 'struct JSScript' has no member named 'debugMode'"

VERIFIED FIXED in mozilla2.0b7

Status

()

Core
JavaScript Engine
--
critical
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: sgautherie, Assigned: standard8)

Tracking

({regression})

Trunk
mozilla2.0b7
PowerPC
Mac OS X
regression
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Thunderbird/1285938796.1285938970.19005.gz&fulltext=1
MacOSX 10.5 comm-central build on 2010/10/01 06:13:16
{
/builds/slave/macosx-comm-central-build/build/mozilla/js/src/jsfun.cpp: In function 'void js_PutCallObject(JSContext*, JSStackFrame*)':
/builds/slave/macosx-comm-central-build/build/mozilla/js/src/jsfun.cpp:1148: error: 'struct JSScript' has no member named 'debugMode'
}

I didn't check but I assume this appeared with the 1-2 tracemonkey landing that just happened...
Dropping importance slightly, since ppc is no longer officially supported for Mozilla-Central. but would be nice for us to still have it.
Severity: blocker → critical

Updated

8 years ago
Depends on: 598444
(Assignee)

Comment 2

8 years ago
I checked in a fix as a bustage fix: http://hg.mozilla.org/mozilla-central/rev/286d3026ae20

If this is wrong, please correct.
Assignee: general → bugzilla
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

8 years ago
V.Fixed, as builds are green.
Status: RESOLVED → VERIFIED
Flags: in-testsuite-
Target Milestone: --- → mozilla2.0b7
You need to log in before you can comment on or make changes to this bug.