Closed Bug 601243 Opened 11 years ago Closed 11 years ago

runtests.py.in should clean up its <TempDir>\tmpXYZ\mochikit.manifest

Categories

(Testing :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: sgautherie, Assigned: jmaher)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

{
678     temp_file = os.path.join(tempfile.mkdtemp(), "mochikit.manifest")
}

I get one more directory and file each time I run a test (suite): my Temp dir is filling up :-(
Flags: in-testsuite-
I have a patch that works, but appears to be leaking on linux debug chrome tests.  odd, since this is related to setup before the browser is launched.  Needless to say until I figure it out or stop seeing that leak I will wait for this patch.
Assignee: nobody → jmaher
Comment on attachment 481816 [details] [diff] [review]
stop making a secondary temp directory in runtests.py (WIP)

2 green try server runs.  Must have been something else in the tree causing those linux debug chrome leaks.
Attachment #481816 - Flags: review?(ctalbert)
Comment on attachment 481816 [details] [diff] [review]
stop making a secondary temp directory in runtests.py (WIP)

Simpler code too, we should have done this to start with ;)  Hindsight always 20/20,I guess.  Nice fix.
Attachment #481816 - Flags: review?(ctalbert) → review+
Landed http://hg.mozilla.org/mozilla-central/rev/54a73ef4d157
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Component: New Frameworks → General
You need to log in before you can comment on or make changes to this bug.