If I click another tab while Print Preview loads, that other tab is shown in the print-preview pane

RESOLVED WORKSFORME

Status

()

Core
Print Preview
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
STEPS TO REPRODUCE:
 1. Open two tabs:
   (a) http://www.mozilla.com/en-US/
   (b) http://www.gutenberg.org/files/2554/2554-h/2554-h.htm
        (The latter is really long page, which takes at least a second
         to load in print-preview.)
 2. While viewing tab (b), choose File | Print Preview
 3. While print preview is loading, click the other tab.

EXPECTED RESULTS: Step (3) should have no effect.

ACTUAL RESULTS: The print preview UI loads, but instead of showing a print preview, it shows the other tab.  (and not even in a paged layout)
(Reporter)

Updated

8 years ago
Summary: Switching tabs during print preview shows that tab in print-preview pane, instead of the print preview → If I click another tab while Print Preview loads, that other tab is shown in the print-preview pane
(Reporter)

Comment 1

8 years ago
Created attachment 480251 [details]
screenshot

Here's a screenshot of the results of the STR.

Note that the page-count is from the page that I tried to print-preview, not of the page that's actually being displayed.  However, if I click "Print", it actually prints the page that's being displayed.  (It prints 1 page of mozilla.com, instead of 536 pages of Crime & Punishment)
(Reporter)

Comment 2

8 years ago
Ran into this bug in current trunk:
Mozilla/5.0 (X11; Linux x86_64; rv:2.0b7pre) Gecko/20101001 Firefox/4.0b7pre

...though it goes back at least as far as Firefox 3.5:
Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1.11) Gecko/20100701 Firefox/3.5.11

One other note: this bug doesn't *require* that the print-previewed page be super-long.  It's just a little easier to reproduce with longer pages.
(Reporter)

Updated

8 years ago
OS: Linux → All
Hardware: x86_64 → All

Comment 3

8 years ago
Maybe this is duplicate of *very* old Bug 177491
(Reporter)

Comment 4

8 years ago
Definitely related.

Not quite a duplicate, though -- that other bug is about *new* tabs opened while in print-preview, whereas this bug is about being able to switch to another tab *just before* entering print-preview.

(The other bug could be fixed by e.g. opening new pages in a completely new Firefox window when the existing window is in print-preview mode.  But that wouldn't fix this bug.  Hence, not really a duplicate.)
(Reporter)

Comment 5

7 years ago
This is WORKSFORME in latest nightly.

That is -- I don't quite get the behavior I labeled as "EXPECTED" in comment 0, but I do get acceptable results now: the tab-change action succeeds, and when print preview finishes loading, it displays the correct content (from the original tab).

Mozilla/5.0 (X11; Linux x86_64; rv:9.0a1) Gecko/20110907 Firefox/9.0a1
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.