List Properties dialog remains on the screen

VERIFIED FIXED in mozilla0.9

Status

()

Core
Editor
P3
normal
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: Srinivasa Rao Borusu, Assigned: Charles Manske)

Tracking

Trunk
mozilla0.9
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.73 [en] (WinNT; I)
BuildID:    2000101014

I tried to insert a unnumbered bullet and after inserting it I reopened the List 
Properties dialog and selected none under List type and clicked on the OK 
button, List properties dialog remains on the screen.

Reproducible: Always
Steps to Reproduce:
1. Open New Composer window.
2. Select Format->List->List properties
3. Select Bullet(Unnumbered) List as List Type and Solid circle as Bullet Style.
4. Click on OK button.
5. Again Select Format->List->List Properties
6. Now Select None under List Type
7. Click on OK button.

Actual Results:  List Properties dialog remains on the screen

Expected Results:  It should disappear from the screen and the solid circle in 
the composer window should go off.

Comment 1

17 years ago
following steps to repro i get this error in console with linux sea build 20001114

JavaScript error:
 line 0: uncaught exception: [Exception... "Component returned failure code:
0x80004003 (NS_ERROR_INVALID_POINTER)
[nsIEditorShell.GetElementOrParentByTagName]"  nsresult: "0x80004003
(NS_ERROR_INVALID_POINTER)"  location: "JS frame ::
chrome://editor/content/EdListProps.js :: onOK :: line 333"  data: no]

After this, the dialog-box became a "ghost" - flat blue and outlined but no
content, and composer editing area froze. Menuline was still intact and i could
close composer.

Resolving as new, OS: All.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows NT → All

Comment 2

17 years ago
*** Bug 60126 has been marked as a duplicate of this bug. ***

Comment 3

17 years ago
reassign to jfrancis
Assignee: beppe → jfrancis
Target Milestone: --- → mozilla0.9

Comment 4

17 years ago
charlie, can you look into why GetElementOrParentByTagName() is failing?
Assignee: jfrancis → cmanske
(Assignee)

Comment 5

17 years ago
I'll look into it.
Status: NEW → ASSIGNED
(Assignee)

Comment 6

17 years ago
Created attachment 19342 [details] [diff] [review]
Fix for bug

Comment 7

17 years ago
I had a zombie List Properties dialog box when trying to make a list item no 
longer a list.  The window could be dragged around, leaving a trail of edges 
everywhere.  The program continued to work, including with the cursor in the 
middle of the box and its trails.

A demo of the bug is contained within:

  http://gair.firstpr.com.au/public-files/mozilla-bugs/mb-comp-space-3.html

This is with a nightly build, Win98, 2000112908.  It happened every time I 
tried.


(Assignee)

Comment 8

17 years ago
We can now remove a list from the List Properties dialog (that what was causing
the described behavior.)
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 9

17 years ago
verified in 1/17 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.