Hide the Private Browsing jumplist entry when inside permanent PB mode

RESOLVED FIXED in Firefox 4.0b7

Status

()

Firefox
Private Browsing
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Away for a while, Assigned: Away for a while)

Tracking

Trunk
Firefox 4.0b7
x86
Windows 7
Points:
---
Dependency tree / graph
Bug Flags:
in-litmus ?

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
It doesn't make any sense for us to show the option to quit PB mode in the jumplist menu if the permanent PB mode is active (see also bug 601253).
(Assignee)

Comment 1

7 years ago
We support turning on the PB mode from within the preferences UI, so I think this should block 4.0 (especially since that it's a really easy fix).
blocking2.0: --- → ?
(Assignee)

Updated

7 years ago
Depends on: 568816
(Assignee)

Updated

7 years ago
Depends on: 601253
(Assignee)

Comment 2

7 years ago
Created attachment 480298 [details] [diff] [review]
Patch (v1)
Attachment #480298 - Flags: review?(dolske)
Comment on attachment 480298 [details] [diff] [review]
Patch (v1)

Wasn't sure if the open() change made sense, but I see we already disable Tools -> Stop Private Browsing when in permanent PB mode, so it's consistent with that.
Attachment #480298 - Flags: review?(dolske) → review+
blocking2.0: ? → final+
(Assignee)

Updated

7 years ago
Whiteboard: [needs landing]
Flags: in-litmus?
(Assignee)

Comment 4

7 years ago
http://hg.mozilla.org/mozilla-central/rev/6e83c2d238c1
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Whiteboard: [needs landing]
Target Milestone: --- → Firefox 4.0b8

Updated

7 years ago
Target Milestone: Firefox 4.0b8 → Firefox 4.0b7

Comment 5

7 years ago
Current latest-trunk always shows "Enter private browsing" entry in jumplist when permanent PM mode is enabled. Is that ok? Is that a regression?
When firefox is closed and I select that entry, firefox will not open. Otherwise (when firefox is already open) nothing happens.

Updated

7 years ago
Depends on: 632039
You need to log in before you can comment on or make changes to this bug.