applet does not work the very first time unless mouse is clicked outside applet area

RESOLVED INVALID

Status

Core Graveyard
Java: OJI
P3
normal
RESOLVED INVALID
18 years ago
8 years ago

People

(Reporter: Stephen Moehle, Assigned: Joshua Xia)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Navigating away from the applet at the above URL and back to it causes the
applet's UI to be unresponsive.  Clicking on buttons has no effect; radio
buttons cannot be selected, etc.

To reproduce:
1) Go to the above URL.
2) Click on the "Next Question" button a few times.  You probably get the idea.
3) Click on the Back arrow to go back in session history.
4) Click on the Forward arrow to return to the applet.
5) Click on the "Next Question" button.  Oops!  Nothing happens!
6) Click on the "English" radio button.  Oops!  Cannot select English!
7) Click anywhere else on the page.  Now steps 5 and 6 will work fine.

This is about 80% reproducible, so try it a few times before marking this bug WFM.

Tested on Mozilla trunk build 111408 and 11/11 with the Java plugin from NS6.
(Reporter)

Comment 1

18 years ago
Ok.  Forget about the back and forwards buttons.  Holding the mouse over the
applet while it is loading causes the applet's UI to be unresponsive.

To really reproduce:
1) Go to the above URL.
2) While the applet is loading, hold the mouse over the applet which is in the
upper left part of the page.  If you miss the applet the first time, simply
reload the page, and try again.
3) Now steps 5 and 6 above should fail as described.

Using these steps, the bug is 100% reproducible.

I should also mention that this happens in NS6 as well.
Summary: Back and forwards navigation causes focus problems for applet → Holding mouse over applet while it is loading causes focus problems

Comment 2

18 years ago
I see the same behaviour on 4.x and mozilla (20001116). In fact, "next Question"
button does not display anything for me in the text areas.:(

Comment 3

17 years ago
Both bugs described work fine for me on
Platform: PC
OS: Windows 98
Mozilla Build: 2000121804 Trunk Build M18

Comment 4

17 years ago
let's close this then.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 5

17 years ago
I do not think you can close a bug because someone says it works on Win98 and it
was reported on Linux.  And I can assure you that the applet does work in both
Mozilla and NN4 with the exception of the bug I reported here.  Unfortunately I
cannot test the bug myself since I cannot get Java to work at all under Linux
any more.

Changed the URL to reflect the fact that I have moved my web site.
(Reporter)

Comment 6

17 years ago
Finally got Java running again, and this bug still happens in Mozilla 121808 on
Linux.  Let me try to explain one more time what the bug is since my previous
explanations may have led to this bug being inadequately tested before being
marked WFM.

In Linux, holding the mouse over the applet while it is loading causes focus
problems for the applet including buttons that do nothing when clicked and radio
buttons that cannot be set.  After this happens, you can click in the browser
window outside of the applet and then click on the applet again.  Everything
will work fine after that.

To reproduce:
1) Go to the above URL.
2) While the applet is loading, hold the mouse over the applet which is in the
upper left part of the page.  If you miss the applet the first time, simply
reload the page, and try again.
3) Click on the "Next Question" button.  Oops!  Nothing happens!  What should
have happened is that a spanish word or phrase should appear in the "Question"
text area.
4) Click on the "English" radio button.  Oops!  Cannot select English!
5) Click somewhere on the page that is not part of the applet such as the
long-winded text below the applet.  Now steps 3 and 4 will work fine.

Reopening for reevaluation.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 7

17 years ago
Looks like a complete bug report.  I can't reproduce it on Win 98, but I will 
confirm it.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

17 years ago
well, I can see the flicker thing that you mention(linux 0108 trunk). However I 
do not think that it is an issue at all(i will change the summary). However, the 
applet does not work the very first time as you have mentioned in 2&3. 
Confirming and marking new.
Summary: Holding mouse over applet while it is loading causes focus problems → applet does not work the very first time unless mouse is clicked outside applet area

Comment 9

17 years ago
I would wager this has something to do with the timing of the XReparentWindow() 
call.  Steve, can you please comment?
Assignee: edburns → skatz

Comment 10

17 years ago
SPAM: reassigning all OJI bugs to new OJI QA, pmac ( 227 bugs)
QA Contact: shrir → pmac

Comment 11

16 years ago
Testcase is not valid anymore (i got "page not found" error).
Please update testcase url or we will close this bug as invalid.

Comment 12

16 years ago
Please assign this to a more appropriate person.
Assignee: skatz → joe.chou

Comment 13

16 years ago
1,5 month later... no response from reporter -> close?

Updated

16 years ago
QA Contact: pmac → petersen
(Assignee)

Comment 14

16 years ago
reassign to me
Assignee: joe.chou → joshua.xia

Comment 15

15 years ago
->INVALID per comment 11
Status: NEW → RESOLVED
Last Resolved: 17 years ago15 years ago
Resolution: --- → INVALID

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.