If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Assertion failure: obj->isNative()" with iframe, marquee, __proto__

RESOLVED WORKSFORME

Status

()

Core
XBL
--
critical
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

(Blocks: 2 bugs, {assertion, testcase})

Trunk
x86
Mac OS X
assertion, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 480302 [details]
testcase (asserts fatally when loaded)

Assertion failure: obj->isNative(), at js/src/jslock.cpp:1238
(Reporter)

Comment 1

7 years ago
Created attachment 480303 [details]
stack trace
(Reporter)

Comment 2

7 years ago
An opt build doesn't crash on the testcase.
This works for me now. Jesse, please reopen if you can still reproduce it.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

6 years ago
Crashtest: http://hg.mozilla.org/mozilla-central/rev/f45e294eca4b
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.