Closed Bug 601326 Opened 12 years ago Closed 12 years ago

Shortcut says Fennec if installing over a nightly build

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: tchung, Unassigned)

Details

Attachments

(1 file)

The Shortcut name says Fennec, despite the icon showing Firefox.  I installed the beta 1 candidate over the latest nightly.

* See screenshot.  Note: this works fine when installing beta 1 with no fennec pre-installed.

REpro:
1) install a fennec trunk build (20101001).  Add the fennec shortcut to your space.  (notice its a fennec icon with the title "Fennec")
2) do not uninstall.  now go to beta 1 build candidate, and install beta 1 over the existing fennec build
3) When completed, verify the shortcut updates to Firefox icon, but keeps the "Fennec" title

Expected:
- "Firefox" title and icon

Actual:
- Firefox icon but "Fennec" title
build ID is Mozilla/5.0 (Android; Linux armv71; rv:2.0b7pre) Gecko/2010001 Firefox/4.0b7pre Fennec/4.0b1
Attached image Fennec Title screenshot
how did you install the beta over a nightly. They're signed with different keys, so this shouldn't be possible.
although it should be possible to install the beta over the alpha, which could show the same problem.  I'm still curious which build you had installed and which build you installed over it.

If you didn't do anything funky, our beta is signed with the wrong key.
I publish the Android release build with both the nightly and release keys -- this is for future automated tests, since the SUT agent will be signed with the nightly key.

(build1/unsigned/android-r7/fennec.apk : nightly key;
 build1/android-r7/fennec.apk          : release key)
oh right, i installed the unsigned bits that aki generated intially with the nightly key.  If this is an invalid scenario that users will not hit, then feel free to invalidate the status.
Can you reproduce this by installing the alpha that was signed with the release key and then installing the beta over it?
Yep, I can confirm that this happens when going from 2.0a1 (and a shortcut is put onto my home screen) to 4.0b1.
tracking-fennec: --- → ?
do you only see this with a homescreen shortcut? I installed b1 over a1 and the item in my menu has the right icon and name.
Yeah, it was only with a homescreen shortcut. The firefox icon and name showed up when there was no shortcut on the homescreen.
Similarly when you look at the list of applications to uninstall it I see "Fennec" and a puzzle piece icon. Tapping uninstall does show the right icon and Firefox in the uninstall confirmation though.
as far as I can tell, this is an OS bug in the home screen of 2.1. I don't think there is much we can do, so marking as won't fix
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WONTFIX
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.