Primitive objects should not be inspectable in the console

RESOLVED DUPLICATE of bug 598357

Status

RESOLVED DUPLICATE of bug 598357
8 years ago
2 months ago

People

(Reporter: dangoor, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
STR:

1. enter 1+1 in the Web Console
2. see that the value 2 is displayed in console
3. see that it's displayed as a clickable value
4. click it
5. empty Object Inspector panel appears

Expected:

3. not displayed as a clickable value
5. no Object Inspector panel is displayed
This is already partially covered by bug 595195, which is now superseded by bug 598357 - please read bug 598357 comment 2.
(Reporter)

Comment 2

8 years ago
Yes, the patch for bug 598357 does seem to deal with this as well. Thanks for the pointer to how broadly that patch fixes things.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 598357

Updated

2 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.