Closed Bug 601358 Opened 9 years ago Closed 9 years ago

d3d10 compilation failure without d2d compilation enabled

Categories

(Core :: Graphics, defect, blocker)

x86
Windows XP
defect
Not set
blocker

Tracking

()

RESOLVED FIXED
mozilla2.0b7

People

(Reporter: jacek, Assigned: jacek)

References

Details

Attachments

(1 file)

D3D10 layers code assumes that d2d support is enabled, so disabling d2d should imply disabled d3d10.
Attachment #480388 - Attachment is patch: true
Attachment #480388 - Flags: review?(bas.schouten)
Assignee: nobody → jacek
(In reply to comment #0)
> Created attachment 480388 [details] [diff] [review]
> fix v1.0
> 
> D3D10 layers code assumes that d2d support is enabled, so disabling d2d should
> imply disabled d3d10.

I'm okay with this I think.. But why would D2D be disabled and D3D10 be available?
(In reply to comment #1)
> I'm okay with this I think.. But why would D2D be disabled and D3D10 be
> available?

Generally, it's because of --with-windows-version= configure option that sets explicitly not to use newer APIs and if set to something less than 610, d2d is disabled although headers may be available. In my case I use it to compile on mingw, because mingw's headers are not yet good enough to build all win7 features, although some parts like d3d10 are available.
Comment on attachment 480388 [details] [diff] [review]
fix v1.0
[Checked in: See comment 8]

OK, sorry, I didn't know that was an existing build configuration.
Attachment #480388 - Flags: review?(bas.schouten) → review+
Attachment #480388 - Flags: approval2.0?
Thanks for quick review.
Component: GFX: Color Management → Graphics
QA Contact: color-management → thebes
Comment on attachment 480388 [details] [diff] [review]
fix v1.0
[Checked in: See comment 8]

This is approved for checkin *after* beta 7.
Attachment #480388 - Flags: approval2.0? → approval2.0+
Duplicate of this bug: 603532
(In reply to comment #6)
> *** Bug 603532 has been marked as a duplicate of this bug. ***

Damn: this patch was approved to land a week before I lost my time on this issue!

Could you land my patch (for its added comment...) there with the approval here asap?
Thanks.
Status: NEW → ASSIGNED
Flags: in-testsuite-
Severity: normal → blocker
Depends on: 546514
(In reply to comment #7)
> (In reply to comment #6)
> > *** Bug 603532 has been marked as a duplicate of this bug. ***
> 
> Damn: this patch was approved to land a week before I lost my time on this
> issue!

Yeah, it was waiting for b6 back then...

> Could you land my patch (for its added comment...) there with the approval here
> asap?

http://hg.mozilla.org/mozilla-central/rev/a6e70b28834f
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Attachment #480388 - Attachment description: fix v1.0 → fix v1.0 [Checked in: See comment 8]
Thanks.
Target Milestone: --- → mozilla2.0b8
Target Milestone: mozilla2.0b8 → mozilla2.0b7
You need to log in before you can comment on or make changes to this bug.