Arabic text not included in Find results if it contains diacritics

RESOLVED DUPLICATE of bug 202251

Status

()

Core
General
RESOLVED DUPLICATE of bug 202251
7 years ago
7 years ago

People

(Reporter: Majid Al-Dharrab, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; ar; rv:1.9.0.19) Gecko/2010040121 Ubuntu/9.04 (jaunty) Firefox/3.0.19
Build Identifier: 

When you search for a text without typing in the letters with diacritics exactly the same way it is in the original text, it will be ignored.

Reproducible: Always

Steps to Reproduce:
1. Load a page in Arabic that has diacritics (Harakat).
2. Use the Find tool to search for a word that contains diacritics. Do not type in the diacritics (assuming they will be excluded from the text when it's checked).
Actual Results:  
Example:
"هذه الجُملة مثال."
When you search for: "الجملة" nothing will be returned.


Expected Results:  
Expected result: return "الجُملة".
All words containing the search term should be found even if they use diacritics.

I think this problem can be solved if the Find function searches in a version of the text that is stripped of diacritics unless a diacritic is found in the search term.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 202251
You need to log in before you can comment on or make changes to this bug.