"Assertion failure: !SHAPE_FETCH(spp),"

RESOLVED DUPLICATE of bug 601395

Status

()

--
critical
RESOLVED DUPLICATE of bug 601395
8 years ago
6 years ago

People

(Reporter: gkw, Unassigned)

Tracking

(Blocks: 1 bug, {assertion, regression, testcase})

Trunk
x86
Linux
assertion, regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

for (let d in [(0)]) let(b = (let(e) {}), d

asserts js debug shell on TM changeset 0230a9e80c1f without -m or -j at Assertion failure: !SHAPE_FETCH(spp),
blocking2.0: --- → ?
autoBisect shows this is probably related to the following changeset:

The first bad revision is:
changeset:   54650:427282865362
user:        Bill McCloskey
date:        Wed Sep 29 13:21:36 2010 -0700
summary:     Bug 535912 - Eliminate blockChain from JSStackFrame (r=cdleary)
Blocks: 535912
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 601395

Updated

8 years ago
blocking2.0: ? → betaN+
A testcase for this bug was automatically identified at js/src/jit-test/tests/basic/bug601402.js.
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.