crash under Windows XP [@ operator new(unsigned int) | js::Parser::markFunArgs(JSFunctionBox*, unsigned int) ]

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash, regression})

Trunk
x86
Windows XP
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

7 years ago
Build : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20101002 Firefox/4.0b7pre

This is a new crash signature that appeared since b7pre/20100929 build.
It happens on Windows XP.
It is #4 top crasher for b7pre/2010102 build.

Signature	operator new(unsigned int) | js::Parser::markFunArgs(JSFunctionBox*, unsigned int)
UUID	2d11ac04-eea4-411e-ad96-49c7a2101002
Time 	2010-10-02 15:36:30.439032
Uptime	44
Last Crash	211 seconds (3.5 minutes) before submission
Install Age	4241 seconds (1.2 hours) since version was first installed.
Product	Firefox
Version	4.0b7pre
Build ID	20101002041357
Branch	2.0
OS	Windows NT
OS Version	5.1.2600 Service Pack 2
CPU	x86
CPU Info	AuthenticAMD family 6 model 10 stepping 0
Crash Reason	Unhandled C++ Exception
Crash Address	0x7c812a5b
App Notes 	AdapterVendorID: 5333, AdapterDeviceID: 8a01
EMCheckCompatibility	False

Frame 	Module 	Signature [Expand] 	Source
0 	kernel32.dll 	RaiseException 	
1 	mozcrt19.dll 	_CxxThrowException 	throw.cpp:159
2 	mozcrt19.dll 	operator new 	obj-firefox/memory/jemalloc/crtsrc/new.cpp:57
3 	mozjs.dll 	js::Parser::markFunArgs 	js/src/jsparse.cpp:2010
4 	mozjs.dll 	js::Compiler::compileScript 	js/src/jsparse.cpp:895
5 	mozjs.dll 	JS_EvaluateUCScriptForPrincipals 	js/src/jsapi.cpp:4758
6 	mozjs.dll 	JS_EvaluateUCScriptForPrincipalsVersion 	js/src/jsapi.cpp:4740
7 	xul.dll 	nsJSContext::EvaluateString 	dom/base/nsJSEnvironment.cpp:1704
8 	xul.dll 	nsScriptLoader::EvaluateScript 	content/base/src/nsScriptLoader.cpp:813
9 	xul.dll 	nsScriptLoader::ProcessRequest 	content/base/src/nsScriptLoader.cpp:716
10 	xul.dll 	nsScriptLoader::ProcessPendingRequests 	

The regression range is :
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c257bfb8cad0&tochange=a60414d076b5

More reports at:
http://crash-stats.mozilla.com/report/list?product=Firefox&query_search=signature&query_type=exact&query=&range_value=4&range_unit=weeks&hang_type=any&process_type=any&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&admin=&signature=operator%20new%28unsigned%20int%29%20|%20js%3A%3AParser%3A%3AmarkFunArgs%28JSFunctionBox*%2C%20unsigned%20int%29
Crash Signature: [@ operator new(unsigned int) | js::Parser::markFunArgs(JSFunctionBox*, unsigned int) ]

Comment 1

6 years ago
Nothing appearing on any version post FF4b in the past 4 weeks. Resolving as works for me.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.