Request: Allow updates prior to starting Minefield

RESOLVED WONTFIX

Status

()

Toolkit
Application Update
--
enhancement
RESOLVED WONTFIX
7 years ago
4 years ago

People

(Reporter: Andy Backa, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20101002 Firefox/4.0b7pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20101002 Firefox/4.0b7pre

After having a problem getting Minefield to start after a daily update, I wondered if it would be possible to have a switch added to the executable so that I could force Firefox to download an update before starting.

For example: This Saturday's update (02-Oct-2010) caused my x64 build to crash on startup.  If I could start it on Sunday (03-Oct-2010, after the updates have been published) with something like: "firefox.exe -updatefirst" so that it would go retrieve an update, install it, and then start Minefield, hopefully the new update would contain the fix.  If no update is found, a message saying that should be shown before trying to start Firefox.  This would help users having to a full manual update once the fix has been identified.

Reproducible: Didn't try
(Reporter)

Updated

7 years ago
Version: unspecified → Trunk

Updated

4 years ago
Component: General → Application Update
Product: Firefox → Toolkit
Update uses the same code so if it is crashing then it won't be able to update. A better way for nightly is to run tests that prevent people from receiving builds that are broken and I suspect that x64 Windows isn't running all the tests at this time. For builds that aren't broken and crash due to add-ons there is safe mode. Since this suggestion wouldn't solve the problem this is wontfix
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.