Closed Bug 601428 Opened 9 years ago Closed 9 years ago

"Assertion failure: tc->blockChainBox == stmt->blockBox,"

Categories

(Core :: JavaScript Engine, defect, critical)

x86
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 601395
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: gkw, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, regression, testcase)

let({}=[c for(x in[])]){let

asserts js debug shell on TM changeset 0230a9e80c1f without -m or -j at Assertion failure: tc->blockChainBox == stmt->blockBox,
autoBisect shows this is probably related to the following changeset:

The first bad revision is:
changeset:   54650:427282865362
user:        Bill McCloskey
date:        Wed Sep 29 13:21:36 2010 -0700
summary:     Bug 535912 - Eliminate blockChain from JSStackFrame (r=cdleary)
Blocks: 535912
blocking2.0: --- → ?
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 601395
blocking2.0: ? → betaN+
A testcase for this bug was automatically identified at js/src/jit-test/tests/basic/bug601428.js.
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.