Flash Elements do not repaint correctly when scrolled

RESOLVED DUPLICATE of bug 587508

Status

()

Core
Plug-ins
--
major
RESOLVED DUPLICATE of bug 587508
8 years ago
8 years ago

People

(Reporter: Stewart Campbell, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6) Gecko/20100101 Firefox/4.0b6
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6) Gecko/20100101 Firefox/4.0b6

On almost all BBC pages there are embedded flash clips.
I have noticed that if you scroll any of these pages then the embedded flash player stops repainting correctly.


Reproducible: Always

Steps to Reproduce:
1. Open http://www.bbc.co.uk/newsbeat/11446978
2. Scroll the flash player out of view by scrolling all the way to the bottom
3. Scroll it back into view - it won't paint properly.
Actual Results:  
Flash Player doesn't repaint correctly.

Expected Results:  
Should repaint properly.
(Reporter)

Comment 1

8 years ago
Created attachment 480496 [details]
Image showing correct and broken.

Attached image showing the problem.

Also, I discovered that if you switch to a new tab and back, the painting is fixed, so it seems to be a scrolling only problem.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 587508

Comment 3

8 years ago
This is fixed in nightly builds, so the problem should be gone in beta 7. Thanks for the report.
You need to log in before you can comment on or make changes to this bug.