Sync UI: "I have lost my Sync Key" should clear Weave.Service.passphrase

RESOLVED DUPLICATE of bug 630885

Status

Cloud Services
Firefox Sync: UI
RESOLVED DUPLICATE of bug 630885
8 years ago
7 years ago

People

(Reporter: philikon, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

When signing up a computer to an existing account, if you get the Sync Key wrong, you're given the option to change it. But it's impossible to change it to the Sync Key that you just tried to log in with because that has been stored in Weave.Service.passphrase and the UI now thinks that's your existing Sync Key ("The new Sync Key cannot be the same as your Sync Key").

Updated

8 years ago
Blocks: 566162
Note that with bug 603489 or in the aftermath thereof we're removing the ability to provide a custom Sync Key, rendering this bug obsolete.
This bug isn't quite as obsolete as I hoped it would be. It's true that with new crypto we no longer allow custom Sync Keys, but the bug remains. It's even slightly more annoying now because we now always show a link for a resetting your Sync Key which will display "undefined" if you haven't entered anything yet.
Summary: "I have lost my Sync Key" should clear Weave.Service.passphrase → Sync UI: "I have lost my Sync Key" should clear Weave.Service.passphrase
(In reply to comment #2)
> This bug isn't quite as obsolete as I hoped it would be. It's true that with
> new crypto we no longer allow custom Sync Keys, but the bug remains. It's even
> slightly more annoying now because we now always show a link for a resetting
> your Sync Key which will display "undefined" if you haven't entered anything
> yet.

Worse even, the dialog doesn't work properly. Fwd-duping this to bug 630885 which fixes this.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 630885
You need to log in before you can comment on or make changes to this bug.