Tabitem doesn't get removed when a tab is removed from tabstrip

RESOLVED WORKSFORME

Status

P2
normal
RESOLVED WORKSFORME
8 years ago
3 years ago

People

(Reporter: robarnold, Unassigned)

Tracking

({qawanted})

Trunk
x86
Windows 7
qawanted

Details

(Reporter)

Description

8 years ago
Every once in a while, I'll close a tab on the tab strip but it doesn't quite disappear. It seems to be kept alive in panorama except that I can neither close it there nor switch to it. Trying to switch to it gives no warnings, errors or other messages in the error console. It just zooms the image as if it were to switch and then resets the view as if I hadn't clicked it at all (except that the thumbnail is slightly moved or resized). Sometimes I can see an empty tab on the tabstrip (no content, just a slightly wider gap between tabs).
(Reporter)

Comment 1

8 years ago
Seem to somehow have triggered some messages - these do not always occur!

TypeError: tab.linkedBrowser.currentURI is undefined = {message: 'tab.linkedBrowser.currentURI is undefined', fileName: 'chrome://browser/content/tabview.js', lineNumber: 4879, stack: 'TabItems__update([object XULElement])@chrome://browser/content/tabview.js:4879
TabItems_heartbeat()@chrome://browser/content/tabview.js:4981
TabItems_resumePainting()@chrome://browser/content/tabview.js:5019
()@chrome://browser/content/tabview.js:4462
(28)@chrome://browser/content/tabview.js:613
', name: 'TypeError', }
Blocks: 598154
Priority: -- → P2
Please provide steps to reproduce which would help us to fix this bug.
Summary: Phantom tabs → Tabitem doesn't get removed when a tab is removed from tabstrip

Comment 3

8 years ago
This bug seems to be related to / caused by bug 585785 and bug 608589.

It seems that when a tab fails to close properly, it always leaves a remnant in the tab bar (the slightly wider gap, described in comment 0).
Additionally, it sometimes (but not always) leaves a non-functional tabitem in TabCandy.

Comment 4

8 years ago
bugspam (moving b9 to b10)
Blocks: 608028

Comment 5

8 years ago
bugspam (removing b9)
No longer blocks: 598154
Rob, Andreas, I'm unable to reproduce this bug. If STR which consistently produces this, or even a screen capture, could be provided, that would be helpful.
Blocks: 627096
No longer blocks: 608028
Keywords: qawanted
Whiteboard: [WFM?]

Comment 7

8 years ago
I can't reproduce the bug anymore.
Thanks for letting us know. Closing worksforme. Please reopen if this becomes an issue again.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Whiteboard: [WFM?]
(Assignee)

Updated

3 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.