missing cookies.txt file breaks compatibility with third-party tools that consume it (e.g. wget)

RESOLVED WONTFIX

Status

()

Firefox
General
RESOLVED WONTFIX
7 years ago
7 years ago

People

(Reporter: Barry Kelly, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10

This is approximately a duplicate of #437517, but that bug has been closed and "Tyler Downer [Triage]" is ignoring replies, saying that the bug has "No reply".

Third party tools - like wget with the --load-cookies option - consume the Netscape cookies.txt file. This is primarily useful for automated downloads from sites that require a login, especially those with logins that are hard to automate, e.g. captchas.

Since Firefox 3.0, this file is no longer generated; instead, cookies are stored in a sqlite db, cookies.sqlite. This is infinitely less useful for third-party consumption, ad-hoc consumption, etc.

There's no simple workaround that I'm aware of, apart from manually and laboriously copying and pasting cookie names and values from the UI into a command line. That gets old really quickly.

Just writing the cookies.txt file would be sufficient.

I'm currently forced to run Firefox 2.0.0.20 to get around this issue.

Reproducible: Always

Steps to Reproduce:
1. Start Firefox
2. Log in to a site that stores a cookie to maintain login status
3. View profile directory in preferred shell and note absence of cookies.txt containing cookie from login
Actual Results:  
cookies.txt file is missing and doesn't contain persistent cookies.

Expected Results:  
cookies.txt file should exist and contain persistent cookies stored by web sites.
There are reasons why Gecko is using the sqlite database and we will not switch back to a txt file.
Your case is a perfect example for an addon.
You are lucky because you don't have to write your own addon, i found this with a simple "cookie export" search :
https://addons.mozilla.org/de/firefox/addon/66579/

marking wontfix
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.