Font Size Changes During Composition

RESOLVED DUPLICATE of bug 250539

Status

Thunderbird
Message Compose Window
--
major
RESOLVED DUPLICATE of bug 250539
7 years ago
2 years ago

People

(Reporter: KitchM, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.10) Gecko/20100916 Firefox/3.6.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.9) Gecko/20100916 Lightning/1.0b2 Lanikai/3.1.4

After checking all locations for font size setting and beginning to compose a message, the font size at the end of the email will be a smaller default size than the one preferred.

Reproducible: Always

Steps to Reproduce:
1.Start new message in safe mode
2.Set the font size a little larger and type a line of text
3.Press Return or Enter
4.Font size will revert to smaller
Actual Results:  
Even if setting all of the known options for default font size, this will often happen, with no discernable source.

Expected Results:  
Fonts in message should stay at the default size unless changed, and then stay at the selected size unless changed.
Whiteboard: dupme?
Whiteboard: dupme? → dupme

Comment 1

7 years ago
I am assuming that you are composing in HTML because of your "size" reference.
I am not able to reproduce this using:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2.12pre) Gecko/20101002 Lanikai/3.1.5pre ID:20101002002015

Although I haven't seen this exact symptom reported, this in probably a dup of bug 597784

This is fixed for the .5 release which should happen within a week.

KitchM,
Could you try with a nightly, or retry after 1.1.5 and mark this bug worksforme if that fixes the problem for you.

Comment 2

7 years ago
This annoying bug has not been fixed for 3.1.5
When typing an email, the font often changes to default size for no apparent reason.

Comment 3

7 years ago
I found that changing the signature from a plain text file to embedded html fixed the problem for my client. It also doesn't seem to occur if you don't have a signature enabled.

Comment 4

7 years ago
I don't have a signature and it still happens.
The way to fix it whilst editing is to press the 'end' key, then backspace.
Would be nice if thunderbird could fix this properly!

Comment 5

7 years ago
Maybe I am reporting this on the wrong bug report. There seem to be a few issues with similar symptoms.

Comment 6

7 years ago
Can't find any other appropriate/similar bug. Will this bug just be ignored? It's driving me mad - I have to type my text in the middle of a sentence just to prevent the font jumping in size!

Please can anyone help - I'm sure I'm not the only one experiencing this utter frustration.

Comment 7

7 years ago
Same here. This seems the most appropriate bug.

On occasion after editing, when replying to someone, your font will change to the size/type of the text at the beginning of the e-mail you are replying to (the "On xx/xx/xxxx, Joe Blow wrote:" message).

Steps to reproduce

1) Don't have "Variable Width" as your composition font.
2) Reply to an e-mail and start typing.
3) Go back to edit something you already typed, then hit END to return to the end of the line. Notice the font drop-down box changes from your font to "Variable Width". Anything you now type is Variable Width. Grr.

Comment 8

7 years ago
I *do* have Variable Width set as the default HTML font, with size 'small'.
If I reply to an email, the existing text seems to be a mixture of fonts and sizes - and when I start typing my default font (small, variable) is correctly used. But if I make any typing mistakes, or stray from the current paragraph then BAM! Font switches to medium size whenever new text is typed.
Grrrr x2

Comment 9

7 years ago
Exactly same problem 3.1.7 Macintosh. Recommended workaround: install quoteandcomposemanager does not solve problem.

Comment 10

7 years ago
Agree completely with m-at-think-inc: 3.1.7 Mac; quoteandcomposemanager doesn't fix. This problem occurs when I move from the paragraph I'm typing in and then come back to that paragraph, as Will said.  I now hit the tab key several times before I start typing to set up OK paragraphs; doesn't always eliminate the font change, though.
Whiteboard: dupme → dupeme

Comment 11

6 years ago
This font size changing bug is the major and only complaint I have with Thunderbird.  I use a larger font owing to poor vision.  It will often change after an enter and further typing often to a smaller font.

I usually use, variable width and enhanced size Arial 30 pt.  After a bit of typing, it often reverts to a smaller font after a period or an enter is struck.  It is a very annoying bug in an otherwise excellent email client program.  I have seen others mention it on the web, but this is the first time I have navigated to the bug page to see what if any resolution of the issue has been made.  I was hoping someone would find and address this bug.

I have just tried using the following fix by creating a userChrome.css file in wordpad and saving it as userChrome.css in C>users>[Name]>AppData>Roaming>Mozilla>Firefox>Profiles>qa24rhbsdefault>chrome as described in http://kb.mozillazine.org/Pane_and_menu_fonts  (Vista 32 bit)

So far it seems to have worked.  More later.

Comment 12

6 years ago
The change in font size that was driving me crazy seems to have been fixed: it hasn't happened to me for some months now, when I'm typing Thunderbird emails. (I sure hope that saying so isn't a jinx!)

Comment 13

6 years ago
(In reply to hamiglorr from comment #12)
> The change in font size that was driving me crazy seems to have been fixed:
> it hasn't happened to me for some months now, when I'm typing Thunderbird
> emails. (I sure hope that saying so isn't a jinx!)

Great, what changed?  What version of Thunderbird are you using?  I reported earlier 2011-06-21 that mine seemed to be fixed.  It wasn't.  The changes I made in the userChrome.css file only affected Foxfire and not Thunderbird.

Comment 14

6 years ago
I'm using 3.1.11 and the problem still exists. grrrrrr....

Comment 15

6 years ago
I'm using Thunderbird 5.0 on an iMac. I don't do anything fancy in composing my emails - I just send simple messages, rather like paper memos would look.  I think I'm typing in HTML, not plain text, and with the cursor in the body of the message, the settings say "Body Text" & "Variable Width".  

If I click on "Tools" > "Quote & Compose Manager" > "Fonts", the top line under "Body message" says "Stabilize predefined font ()" and this is checked "On". Don't know whether or not this has anything to do with the font-size problem.

Comment 16

6 years ago
Thunderbird 5.0 on Mac. There's no Quote and Compose Manager under my Tools!
(and no stabilize font option) My font always reverts back to "variable width" and small. My predefined font is Times New Roman large size - set in Thunderebird - Preferences - Composition - General

Comment 17

6 years ago
Sorry - found it. It's an add-on. I clicked stabilize and now we'll see.

Comment 18

6 years ago
(In reply to m from comment #17)
> Sorry - found it. It's an add-on. I clicked stabilize and now we'll see.

Good luck!

Comment 19

6 years ago
If the add-on is Quote and Compose Manager 0.3.26.1 >options>Font, I have had the "stabilize predefined font () or 0" feature set for some time.  FWIW, it has not helped.  I am still getting the font size changing in mid message.  It will be interesting to see what behavior you get.

Comment 20

6 years ago
I'got a similar complaint:

--------- font size becoming larger without reason ---------------

When answering to a message and having changed the embedded message then, when typing a text, the font size becomes larger - sometimes immediately sometimes on the second line of the text. It's annoying.
I have a Bug in for SeaMonkey 601612. does the same. 

Start composing message in HTML
Set to any size or not set a size.
Start typing. stop typing for just second to collect your thoughts
Start typing again the resulting font size will always be smaller
In most cases, its smaller than normally set size

It started this behavior as soon as I switched to the 2.0 version of SM and has gotten progressively worse with each new version no sometimes it will stwitch size in middle of typing.
Isn't this bug 250539 ?

Comment 23

6 years ago
(In reply to Ludovic Hirlimann [:Usul] from comment #22)
> Isn't this bug 250539 ?

Other related bugs:  203810, 308437, 514265, 536613, 590640

Clearly, this is a big problem for lots of people who word the problem differently so that it ends up in different places.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 250539

Updated

4 years ago
Whiteboard: dupeme

Comment 25

3 years ago
Same problem as everyone else, we use this in our business, sending out 100 emails a day, all individually composed.

We notice it on the reply from customers. We send an email that looks good, the customer replies and we see the fonts are mixed in our original message we sent to the customer. It is bad because some of the words look like we are shouting at the customer.

So... we have been trying to remove all format and then set a format after we compose a message. I suspect a hot key, or a control key accidentally hit during composition and or some ascii code embedded in the message. 

Being a programmer, I would look at trapping for valid ascii characters - we also see see something that could be related, if we use backspace keys, sometimes the word shows up with red underline as if it is misspelled, when it is not. If you do the spell, it adds the word for "instance" might be "iinstance" after doing the spell check - again suggesting embedded control codes.

Brad
help@wolfbay.com
This is an issue that has been ongoing for at least the last 5 versions I even posted a bug report when it first started its either been marked won't fix can't fix or ignored. 
Someone need to get their act in gear and fix the issue. this issue has grown a very long berad like father time.
Did note this applies to any of the last five major versions of Seamonkey as well as Thunderbird.

Comment 28

3 years ago
Same problem here. We have experienced the same as described above, including the spellling as reported by brad@wolfbay. It makes us look very unprofessional vs customers and we have had to revert to Outlook for critical emails, as we don't know what the email will look like when the customer receives them.

We have also been trying to find a way to adjust the font to one size, but you can specify a font size, just "bigger" or "smaller".

This is the only bug that prevents us from switching to Thunderbird and it seems many others too. Are there any updates?

Comment 29

3 years ago
Four years later this problem still persists!!!!!!!!!!!

Comment 30

3 years ago
(In reply to Hardy from comment #29)
> Four years later this problem still persists!!!!!!!!!!!

Yes, it's sad true. I also search for some solution. For now the best idea is install "Compose Toolbar Buttons" add-on. With it you get ability to set direct font size (10, 12 etc.) for marked text. So when you finish writte email you need to select all abnormal text and set one font size for all letters.

It's all now. I also wait for official bug-fix.

Comment 31

3 years ago
I forgot wrote: problem in version 31.2.0, Windows 8.1.
You need to log in before you can comment on or make changes to this bug.