Closed Bug 601683 Opened 12 years ago Closed 12 years ago

Ts regression: 13.7% Ts on 10.6.2

Categories

(Core :: Graphics, defect)

All
macOS
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
blocking2.0 --- final+

People

(Reporter: vlad, Assigned: joe)

References

Details

(Whiteboard: [1 week][softblocker])

> Regression Ts, MIN Dirty Profile increase 13.7% on MacOSX 10.6.2 Firefox
> ---------------------------------------------------------------------------
>    Previous: avg 637.330 stddev 42.249 of 30 runs up to revision babdbb0e411a
>    New     : avg 724.821 stddev 5.155 of 5 runs since revision a518f8ffb813
>    Change  : +87.491 (13.7% / z=2.071)
>    Graph   : http://mzl.la/bwVhfI
>
> Changeset range: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=babdbb0e411a&tochange=a518f8ffb813
>
> Changesets:
>  * http://hg.mozilla.org/mozilla-central/rev/0daed705a12c
>    : ffxbld - Added tag FENNEC_4_0b1_BUILD1 for changeset 4791cfde3ca0. CLOSED TREE
>
>  * http://hg.mozilla.org/mozilla-central/rev/75deb7fd1012
>    : ffxbld - Added tag FENNEC_4_0b1_RELEASE for changeset 4791cfde3ca0. CLOSED TREE
>
>  * http://hg.mozilla.org/mozilla-central/rev/ca49c629bf81
>    : Vladimir Vukicevic <vladimir@pobox.com> - b=600863; implement rough mac gfx blocklist; r=joe
>
>  * http://hg.mozilla.org/mozilla-central/rev/a518f8ffb813
>    : Vladimir Vukicevic <vladimir@pobox.com> - b=600863; disable framebuffer blit optimization for TEXTURE_RECTANGLE targets; r=joe a=b7

Entirely possible that it's the mac gfx blocklist, but I don't understand how.  I can try to back out, but we actually do need it -- without it we're broken on a class of mac hardware that we have to block.

Because it involves some CGL functions, I'm thinking that we should wait one way or the other until bug 600899 gets resolved (install resistors so we get a real GL implementation).
blocking2.0: --- → betaN+
Assignee: nobody → joe
Whiteboard: [1 week]
Whiteboard: [1 week] → [1 week][soft blocker]
Whiteboard: [1 week][soft blocker] → [1 week][softblocker]
If this remains a betaN softblocker, it means that we're willing to ship Firefox 4 with a 14% Ts regression to 10.6 users.  (Note that Joe is on vacation this week...)
blocking2.0: betaN+ → ?
Whiteboard: [1 week][softblocker] → [1 week]
I have no idea what Joe's plans for this bug were, where the 1 week estimate comes from, and what the risk would be. Unfortunately, I don't think this can hardblock shipping.
I'm going to mark this as final+ softblocker. It's very important and if we some how come up with a low risk patch to fix it I would take it. However, I expect it slip.
blocking2.0: ? → final+
Whiteboard: [1 week] → [1 week][softblocker]
Looking at the actual graph, it seems that we've ended up at or below where we were before this regression.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.