-moz-box-shadow and box-shadow add to scrollable area of page when they should not.

RESOLVED DUPLICATE of bug 446693

Status

()

Core
Layout
--
major
RESOLVED DUPLICATE of bug 446693
8 years ago
8 years ago

People

(Reporter: John Lascurettes, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_4; en-us) AppleWebKit/533.18.1 (KHTML, like Gecko) Version/5.0.2 Safari/533.18.5
Build Identifier: Minefield 4.0b7 pre and Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10

Both of the following quotes are from the curren W3C Draft: http://www.w3.org/TR/css3-background/#the-box-shadow
* Shadows do not influence layout and may overlap other boxes or their shadows.</li>
* Shadows do not trigger scrolling or increase the size of the scrollable area.</li>

Note in the test example that box-shadows are included in the overall scrollable area of the body element.

Reproducible: Always

Steps to Reproduce:
1. Set a fixed width child of BODY
2. Add a CSS shadow to that element with a positive offset
3. Narrow the browser window such that the BODY of the window is near (child element + shadow offset) or equal to the width of the child element.
Actual Results:  
The browser chrome shows a horizontal scrollbar. 

Expected Results:  
There should be no horizontal scrollbar until the browser window is narrower than the child element. 

I will be attaching a test case and a screen shot. Webkit performs this test correctly. Presto and Gecko do not. It can affect UI in major websites.
(Reporter)

Comment 1

8 years ago
Created attachment 480816 [details]
Simple HTML/CSS test case with instructions.
(Reporter)

Comment 2

8 years ago
Created attachment 480817 [details]
Screenshot of scrollbar in effect where it should not be

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 446693
You need to log in before you can comment on or make changes to this bug.