Closed Bug 601847 Opened 9 years ago Closed 9 years ago

both "All Pages" and "Desktop" navigation tabs highlighted after fresh start

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: Atoll, Unassigned)

Details

0. Configure Fennec with syncing. Complete a first-time sync.
1. Opened Fennec for the first time since my phone was powered on.
2. Clicked on "Tabs from your other computers", either while grey or black.

At this point, two of the four "navigation" tabs were highlighted as active, "All Pages" and "Desktop".  Clicking either of them had no effect.  Clicking on either "Bookmarks" or "History" resolves both issues.

This bug is only reproducible after a force quit of Fennec or a reboot of the phone.
Summary: grayed out ("disabled"?) "Tabs from your other computers" button still clickable → both "All Pages" and "Desktop" navigation tabs highlighted after fresh start
"Desktop" is disabled until Sync connects. See description in bug 601845.

I'm closing this bug too. Now that you are aware of the strange delayed Sync connection and it's affect on the UI, if you want to file bugs on the styling or behavior go ahead. But this bug is just documenting what is supposed to happen.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 605849
You need to log in before you can comment on or make changes to this bug.