User Added Keyboard Shortcuts Not Active

RESOLVED DUPLICATE of bug 429824

Status

()

defect
RESOLVED DUPLICATE of bug 429824
9 years ago
9 years ago

People

(Reporter: stephane.grenier, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.9) Gecko/20100915 Thunderbird/3.1.4

Adding a new keyboard shortcut via System Preferences for Thunderbird, then launching Thunderbird, new keyboard shortcut appears well next to the command it represents. However, it doesn't work. When hit, the corresponding Menu Command Title is briefly highlighted, as it should, but nothing happens... unless the corresponding Menu is dropped down. Specifically i tried to add a shortcut for Empty Trash, i tried several key combinations, with the same (non-)result.

Reproducible: Always

Steps to Reproduce:
1.Adding a new keyboard shortcut via System Preferences
2.launching Thunderbird
3.hit shortcut
Actual Results:  
nothing

Expected Results:  
typically 'Empty Trash'
>System Preferences for Thunderbird

What is that ? Can you describe a bit more what you are doing and how ?
(In reply to comment #1)
> >System Preferences for Thunderbird
> What is that ? Can you describe a bit more what you are doing and how ?

In System Preferences of the Mac OS, one can add keyboard shortcuts to the applications. In particular i want to add a keyboard shortcut to Thunderbird. I define for instance "apple cmd+0" as the shortcut for "Empty Trash". Once, thunderbird is relaunched, i can see in the dropped down menu that the shortcut is listed next to "Empty Trash". However it only works when the menu is dropped down, but not in a normal use. 

For instance, I send to trash many messages, I hit the "apple cmd + 0", but the trash is not emptied. If i hit again, after dropping down the menu where "Empty Trash" is listed with its new shortcut, and keeping it dropped down, then the shortcut works. In conclusion, the shortcut is not truely behaving like a shortcut.

With hope of being clear... Thanks a lot.
Component: General → Widget: Cocoa
Product: Thunderbird → Core
QA Contact: general → cocoa
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429824
You need to log in before you can comment on or make changes to this bug.