Browser crashes when you select a drop-down list

RESOLVED DUPLICATE of bug 550392

Status

()

--
critical
RESOLVED DUPLICATE of bug 550392
8 years ago
3 years ago

People

(Reporter: rich.merchant80, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 FirePHP/0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 FirePHP/0.4

When you select the drop-down list, the browser crashes. I have used the Jquery plugin Uniform (http://pixelmatrixdesign.com/uniform/) to style the form elements but this seems to crash the browser. I have checked on Safari and it worked ok. IE on mac and PC was fine. Chrome was a bit jittery but still worked. Firefox 3.6.10 on PC just didn't show the list. Only Mac Firefox seemed to crash the browser.

Reproducible: Always

Steps to Reproduce:
1.Load the page http://sbgi.tapdev.co.uk/events/content/179/utility_street_works
2.Select any of the drop-down lists under the heading `Utility Metering`

Actual Results:  
The browser should crash

Expected Results:  
The list of products should be displayed

I am using jquery to check the state of the drop-down, to enable the add to order button. 

I am also using a flowplayer plugin called overlay but this is not working on the drop-down lists but on the share button
firefox-bin[72890:813] *** Assertion failure in -[NSNextStepFrame lockFocus], /SourceCache/AppKit/AppKit-949.54/AppKit.subproj/NSView.m:4755
firefox-bin[72890:813] Mozilla has caught an Obj-C exception [NSInternalInconsistencyException: -[NSNextStepFrame(0x21e7dd00) lockFocus] failed with window=0x21e7dc60, windowNumber=9586, [self isHiddenOrHasHiddenAncestor]=0]
firefox-bin[72890:813] Generating stack trace for Obj-C exception...
(gdb) bt
#0  0x91d09266 in mach_msg_trap ()
#1  0x91d10a5c in mach_msg ()
#2  0x93a7ee7e in CFRunLoopRunSpecific ()
#3  0x93a7faa8 in CFRunLoopRunInMode ()
#4  0x91538300 in -[NSConcreteTask waitUntilExit] ()
#5  0x12741db3 in nsObjCExceptionLog (aException=0x21e52720) at nsObjCExceptions.h:129
#6  0x12746e93 in nsCocoaWindow::Show (this=0x21e7dbb0, bState=1) at widget/src/cocoa/nsCocoaWindow.mm:696
#7  0x12f8543a in nsView::NotifyEffectiveVisibilityChanged (this=0x21f299a0, aEffectivelyVisible=1) at view/src/nsView.cpp:510
#8  0x12f854bd in nsView::SetVisibility (this=0x21f299a0, aVisibility=nsViewVisibility_kShow) at view/src/nsView.cpp:529
#9  0x12f893cb in nsViewManager::SetViewVisibility (this=0x2202ee10, aView=0x21f299a0, aVisible=nsViewVisibility_kShow) at view/src/nsViewManager.cpp:1386
#10 0x129b9ddd in nsComboboxControlFrame::ShowPopup (this=0x1bee9048, aShowPopup=1) at layout/forms/nsComboboxControlFrame.cpp:365
#11 0x129b9fa2 in nsComboboxControlFrame::ShowList (this=0x1bee9048, aShowList=1) at layout/forms/nsComboboxControlFrame.cpp:389
#12 0x129ba252 in nsComboboxControlFrame::ShowDropDown (this=0x1bee9048, aDoDropDown=1) at layout/forms/nsComboboxControlFrame.cpp:740
#13 0x129d66ef in nsListControlFrame::MouseDown (this=0x1bee9168, aMouseEvent=0x22f0f5f0) at layout/forms/nsListControlFrame.cpp:2241
#14 0x129d678f in nsListEventListener::MouseDown (this=0x21f2aed0, aEvent=0x22f0f5f0) at layout/forms/nsListControlFrame.cpp:2810
#15 0x12d7d662 in DispatchToInterface (aEvent=0x22f0f5f0, aListener=0x21f2aed4, aMethod={__pfn = 0x11, __delta = 0}, aIID=@0x136f3e4c) at content/events/src/nsEventListenerManager.cpp:175
...
It also crashes a recent mozilla-central debug build on OSX.
It does not crash on Windows or Linux64, but the dropdown menu
does not appear when clicking the combobox.
Severity: normal → critical
Status: UNCONFIRMED → NEW
Component: General → Widget: Cocoa
Ever confirmed: true
Keywords: crash, testcase-wanted
Product: Firefox → Core
QA Contact: general → cocoa
Hardware: PowerPC → All
I can also easily reproduce this, in FF 3.10 on OS X 10.5.8.

This bug is a dup of bug 550392, but has much better steps-to-reproduce.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 550392
Keywords: testcase-wanted
You need to log in before you can comment on or make changes to this bug.