Browser History / URL suggestion appears broken between FF4b4 and 4b5

RESOLVED INVALID

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED INVALID
8 years ago
7 years ago

People

(Reporter: Ryan Jendoubi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b5) Gecko/20100101 Firefox/4.0b5
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0b5) Gecko/20100101 Firefox/4.0b5

Have been using FF4b6 for a while on Ubuntu Linux, bothered by the fact that the Awesomebar wasn't being so.

Yesterday noticed that while recent History is visible in the History menu, no History appears in the Library.

Opening FF3.6, I saw that all my History is actually still in there, bang up to date - so it's just not showing up in FF4.

Just now downloaded some of the older betas and ascertained that both problems (No History in Library, no URL suggestions) started in FF4b5. When I load up FF4b4 (same machine, OS, user, profile), they both work fine.

I'm almost reluctant to add this information because it might cause investigation down a fruitless path, but I dual boot with WindowsXP SP3, storing my profile info in C:\MozillaProfiles (/media/xp/MozillaProfiles).

It was suggested that it might be a permissions issue, so just to make sure I copied my profile to my Ubuntu home folder, but the same behavior resulted. And just to reiterate, my latest FF3.6 plus all FF4beta versions prior to beta 5, on the same system with the same user and profile settings, do not suffer from these problems.

I have not tested the behavior comprehensively on Windows yet (don't use it that often), but I believe it suffers from the same problem with the most recent beta. I'll add info as to whether Windows too is ok with 4b4.

I have searched extensively on this problem and not come up with anything. Please let me know any other diagnostic steps I can take to help.

Many thanks!

Reproducible: Always

Steps to Reproduce:
1. Open Firefox 4b5 or 4b6
2. Start typing keywords in the Location bar.
3. Open the Library.
Actual Results:  
- No suggestions made by Location bar
- No History items in relevant Library section (Bookmarks all fine)

Expected Results:  
- Search / URL suggestions
- History items can be browsed in the Library.
Have you tried creating a new clean profile?
http://support.mozilla.com/kb/Managing+profiles

you can contact support at http://support.mozilla.com/

Comment 2

7 years ago
Please check if you still have this problem on the latest beta and with a new profile. http://support.mozilla.com/kb/Managing+profiles
(Reporter)

Comment 3

7 years ago
I still have this problem intermittently with both FF3 and the latest 4 betas. Of late it seems to have something to do with having many tabs open at once, or perhaps with the Zotero plugin.

In any case, since it's no longer consistently reproducible, I'm marking it as resolved until I can offer more solid information.

Thank you for taking the time to look over this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.