Build ID in application.ini and pref 'browser.startup.homepage_override.buildID' do not match

RESOLVED FIXED

Status

defect
RESOLVED FIXED
9 years ago
7 months ago

People

(Reporter: Event.H04iz0n, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b7pre) Gecko/20101005 Firefox/4.0b7pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b7pre) Gecko/20101005 Firefox/4.0b7pre

Build ID in application.ini and about:support 'browser.startup.homepage_override.buildID' (which is the same as Firefox.exe->File properties->Version->Build ID) do not match.

There has been confusion about which Build ID is correct; in the latest two nightly forum threads http://forums.mozillazine.org/viewtopic.php?f=23&t=2005457&start=73 & http://forums.mozillazine.org/viewtopic.php?f=23&t=2006153&start=60.

FWIW
In searching to see if this is a know bug (or an expected result), I have found bugs talking about the possibility of dropping the Build ID completely.

Reproducible: Always

Steps to Reproduce:
1. Open the application.ini file in the Minefield application directory, and look at the [App]->BuildID=
2. Open 'about:support' and check 'browser.startup.homepage_override.buildID', or in Minefield directory look at Firefox.exe->file Properties->Version->Build ID.
3. The Build ID in step #1 & 2 are different.
Actual Results:  
The Build ID in "application.ini" and "about:support->browser.startup.homepage_override.buildID" (or Firefox.exe->file Properties->Version->Build ID) are different.

Expected Results:  
The Build ID should match?

If not which Build ID is real?

See attachment.
Reporter

Comment 1

9 years ago
Check Build ID in red circles.
One (or 2, if you count crash ID) in "application.ini" file.
One in "about:support" and a matching ID in "Firefox.exe->File properties->Version->Build ID".
Reporter

Updated

9 years ago
Component: General → Build Config
Version: unspecified → Trunk

Comment 2

9 years ago
I can confirm this on Mozilla/5.0 (Windows NT 6.0; rv:2.0b7pre) Gecko/20101006 Firefox/4.0b7pre ID:20101006041601
application.ini file shows: BuildID=20101006041601
about:support browser.startup.homepage_override.buildID shows: 20101006031215
On my PC there's no "Version" tab on firefox.exe > Properties so I can't really tell that one.
QA Contact: general → build.config

Comment 3

9 years ago
http://kb.mozillazine.org/Browser.startup.homepage_override.mstone :

"When a user starts up their browser, this preference is examined. If its value differs from the browser’s current milestone, then the user is redirected to the homepage specified in startup.homepage_override_url and this preference’s value is updated to the current milestone."

So according to that (not authoritative), the current behavior is correct on first start of a new build, but the build id should update on restart and doesn't.

Note that the homepage_override.buildID pref is sort of "internal use", and is not intended to always be the current build id, so probably shouldn't be recommended as a source of support info.

I suggest morphing the summary to make the bug about the pref not updating as per the knowledge base clip, and let somebody who knows decide if that's intended or a bug.

Comment 4

9 years ago
Forgot to say:

Is "Build Config" the right component (he asks sceptically)? And platform is probably "all", but I can only speak for vista.

Mozilla/5.0 (Windows NT 6.0; rv:2.0b8pre) Gecko/20101007 Firefox/4.0b8pre

Comment 5

9 years ago
Ignore me completely. Just noticed that kb reference is to the wrong pref--milestone vs build id. Sorry.
Reporter

Updated

9 years ago
Whiteboard: [buildbot]
Can't reproduce with 4.0b7 release on mac. Probably something to do with PGO on windows.
Confirmed with the latest win32 nightly using XP.

application.ini & aus query: 20101116042306
firefox.exe props/browser.startup.homepage_override.buildID: 20101116031541
(Same for xul.dll, updater.exe, so probably all the executables)

In the nightly build log [1] there are 
d:/mozilla-build/python25/python2.5.exe /e/builds/moz2_slave/mozilla-central-win32-nightly/build/toolkit/xre/make-platformini.py --buildid=20101116031541 --sourcestamp=a42e9b001bc8 --sourcerepo=http://hg.mozilla.org/mozilla-central /e/builds/moz2_slave/mozilla-central-win32-nightly/build/config/milestone.txt > platform.ini

d:/mozilla-build/python25/python2.5.exe /e/builds/moz2_slave/mozilla-central-win32-nightly/build/toolkit/xre/make-platformini.py --buildid=20101116042306 --sourcestamp=a42e9b001bc8 --sourcerepo=http://hg.mozilla.org/mozilla-central /e/builds/moz2_slave/mozilla-central-win32-nightly/build/config/milestone.txt > platform.ini

I don't see where that gets into application.ini so that may be a red herring.

Ted/Khuey: is this worth fixing ?

[1] http://tinderbox.mozilla.org/Firefox/1289905344.1289915617.3118.gz
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Build ID in application.ini and about:support 'browser.startup.homepage_override.buildID' do not match → Build ID in application.ini and pref 'browser.startup.homepage_override.buildID' do not match
Whiteboard: [buildbot]
Reporter

Comment 8

9 years ago
I have checked recently and it looks like this problem has been fixed in the nightlies.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Component: Build Config → General
Product: Firefox → Firefox Build System
You need to log in before you can comment on or make changes to this bug.