audio element preload attribute set to none (preload = "none") means play() is ignored.

RESOLVED FIXED

Status

()

Core
Audio/Video
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Mark Boas, Assigned: cpearce)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_4; en-US) AppleWebKit/534.3 (KHTML, like Gecko) Chrome/6.0.472.63 Safari/534.3
Build Identifier: 4.0b7pre

In you create an audio element, set that element's preload="none", insert into a page and then retrieve and subsequently tell that element to play() not audio is played.

If you omit preload="none" it will play.
(http://happyworm.com/mftest/ff-bug-test-pass.htm)

Pressing the play button will cause it to play in the first case.



Reproducible: Always

Steps to Reproduce:
1. Navigate to http://happyworm.com/mftest/ff-bug-test-fail.htm
Actual Results:  
No audio is played.

Expected Results:  
Audio should have been played.

This behaviour also exhibited here:
http://www.happyworm.com/jquery/jplayer/latest/demo-01.htm
http://www.happyworm.com/jquery/jplayer/latest/demo-02.htm (alternate items on the playlist will play)
(Reporter)

Comment 1

7 years ago
The user agent filed above is irrelevant. I sent the bug from Chrome as I didn't realise that my user agent would be used. The actual agent of the version of Firefox 4 Beta this bug refers to is :

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b7pre) Gecko/20101005 Firefox/4.0b7pre

Updated

7 years ago
Component: General → Video/Audio
Product: Firefox → Core
QA Contact: general → video.audio
Version: unspecified → Trunk

Updated

7 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

7 years ago
Created attachment 482977 [details] [diff] [review]
Patch

Patch: update preload status at end of play(), and when we update preload status, don't limit preload if we're playing. Includes testcase, and all mochitests pass (on Windows).

Can this bug block2.0 or can this patch have approval2.0 please?
Assignee: nobody → chris
Status: NEW → ASSIGNED
Attachment #482977 - Flags: review?(roc)
(Assignee)

Updated

7 years ago
blocking2.0: --- → ?
Attachment #482977 - Flags: review?(roc) → review+
blocking2.0: ? → betaN+
(Assignee)

Comment 3

7 years ago
http://hg.mozilla.org/mozilla-central/rev/5a67103cdf2b
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

7 years ago
Backed out due to errors in caused by one of the changesets I pushed this with.

http://hg.mozilla.org/mozilla-central/rev/06d7265ab425
http://hg.mozilla.org/mozilla-central/rev/8736e427c0a5

Some of the errors:

Rev3 Fedora 12 mozilla-central opt test mochitests-5/5
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1287262011.1287262859.26658.gz

19554 ERROR TEST-UNEXPECTED-FAIL | /tests/toolkit/content/tests/widgets/test_videocontrols.html | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - [object Event] at undefined:undefined
Thread 0 (crashed)
0  libxul.so!nsMediaCacheStream::Close [nsMediaCache.cpp:f9f10c04dceb : 1891 + 0x6]
1  libxul.so!nsMediaChannelStream::Close [nsMediaStream.cpp:f9f10c04dceb : 498 + 0x8]
2  libxul.so!nsWaveDecoder::Stop [nsWaveDecoder.cpp:f9f10c04dceb : 1372 + 0x8]

19557 ERROR TEST-UNEXPECTED-FAIL | /tests/toolkit/content/tests/widgets/test_videocontrols_audio_direction.html | Test timed out.
19560 ERROR TEST-UNEXPECTED-FAIL | /tests/toolkit/content/tests/widgets/test_videocontrols_video_direction.html | Test timed out.

Rev3 Fedora 12 mozilla-central debug test reftest
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1287261600.1287263280.28360.gz
Lots of failures...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 5

7 years ago
The failures were caused by bug 572579. Landed again without that...

http://hg.mozilla.org/mozilla-central/rev/9cea0be1c4ad
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.