www.mapa.co.il - broken in Firefox 4 (doesn't calculate route) due to a change in navigator.appVersion format

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
Hebrew
--
major
RESOLVED WORKSFORME
8 years ago
3 years ago

People

(Reporter: igorshosh, Unassigned)

Tracking

({regression})

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b6) Gecko/20100101 Firefox/4.0b6
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b6) Gecko/20100101 Firefox/4.0b6

This bug happens on an Israeli map site, when calculating route, it doesn't display the route calculation in FF4.0b6. I have checked and it works fine in FF3.6.



Reproducible: Always

Steps to Reproduce:
1.Enter the aforementioned URL 
2.Copy-paste the following details (from top to bottom). Preferably using a computer with hebrew fonts installed would be best.
ירושלים 
שדרות גולדה מאיר 
   1
ירושלים 
המרפא 
 6
3.Press the green button. 

Actual Results:  
In FF4.0b6 it only shows the popup without the route.

Expected Results:  
If everything works it will show short popup and then a route from A->B (in purple)
(Reporter)

Updated

8 years ago
Summary: Doesn't calculate route for Israeli map site (www.mapa.co.il), works fine in FF3.6.10 → FF4.0b6 Doesn't calculate route for Israeli map site (www.mapa.co.il), works fine in FF3.6.10
(Reporter)

Updated

8 years ago
Version: unspecified → Trunk
(Reporter)

Updated

8 years ago
Severity: normal → major

Comment 1

8 years ago
I couldn't figure out how to copy paste this into the site, but in any case a regression window would be helpful here, since the site could have broken due to an intentional change or due to bug in our code.

https://wiki.mozilla.org/QA/Triage#How_to_Help_with_Regressions_--_Finding_Regression_Windows
Component: General → General
Keywords: qawanted
Product: Firefox → Core
QA Contact: general → general

Updated

8 years ago
Keywords: regression
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> I couldn't figure out how to copy paste this into the site, but in any case a
> regression window would be helpful here, since the site could have broken due
> to an intentional change or due to bug in our code.
> 
> https://wiki.mozilla.org/QA/Triage#How_to_Help_with_Regressions_--_Finding_Regression_Windows

I will see what I can do to help reproduce the exact issue. My guess is the javascript engine. In any case, what I can definitely tell is that it is not a bug in the site, since it works (now) with FF3.6 and doesn't work with FF4.0b6. 

Any suggestions on how I can add traces/debug info that might help you reproduce the issue?
(Reporter)

Comment 3

8 years ago
(In reply to comment #1)
> I couldn't figure out how to copy paste this into the site, but in any case a
> regression window would be helpful here, since the site could have broken due
> to an intentional change or due to bug in our code.
> 
> https://wiki.mozilla.org/QA/Triage#How_to_Help_with_Regressions_--_Finding_Regression_Windows

I found a way to enter the details without the copy/paste (in some cases not all the data is saved in the site URL)

The bottom URL should do all the work for you hopefully.


http://www.mapa.co.il/general/searchresult_locked.asp?SourceX=&SourceY=&SourceAddInfo=&DestinationX=&DestinationY=&DestinationAddInfo=&CurrMapTab=4&CurrHeaderTab=2&SourcePoint=%E4%EE%F8%F4%E0+6+%E9%F8%E5%F9%EC%E9%ED&DestinationPoint=%F9%E3%F8%E5%FA+%E2%E5%EC%E3%E4+%EE%E0%E9%F8+%E9%F8%E5%F9
%EC%E9%ED

Comment 4

8 years ago
OK, thanks.

That page works if I set general.appversion.override in about:config to "5.0 (Macintosh; en-US)". The code that can't handle the change in appVersion is this:

		// Sniff for the navigator Version:
		var arrTemp;
		var strTemp = new String(navigator.appVersion);
		
		arrTemp = strTemp.split(";");
		strTemp = arrTemp[1];
		strTemp = strTemp.replace(" ","");

This broke due to an intentional change in bug 572656.
Assignee: nobody → hebrew
Blocks: 572656
Status: UNCONFIRMED → NEW
Component: General → Hebrew
Ever confirmed: true
Keywords: qawanted
Product: Core → Tech Evangelism
QA Contact: general → hebrew
Summary: FF4.0b6 Doesn't calculate route for Israeli map site (www.mapa.co.il), works fine in FF3.6.10 → www.mapa.co.il - broken in Firefox 4 (doesn't calculate route) due to a change in navigator.appVersion format
Version: Trunk → unspecified

Comment 5

8 years ago
In other words, this will most likely need a fix on the site's end. Please contact them and let them know about this entry.

Apparently we don't have good documentation on this, what we have are these two pages:
https://developer.mozilla.org/en/DOM/window.navigator.appVersion
http://hacks.mozilla.org/2010/09/final-user-agent-string-for-firefox-4/
> Apparently we don't have good documentation on this

Should bug 572656 go back to dev-doc-needed?
The current URL seems to work just fine (there is a purple route and turn-by-turn directions), so I think this is WFM. (Feel free to reopen if the actual Hebrew indicates otherwise.)
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
I suppose I should note that I tested with Aurora 17. It appears that the site has fixed it on their end.
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.