[IE 7] Army of Awesome page has broken layout / functionality

RESOLVED WONTFIX

Status

--
major
RESOLVED WONTFIX
8 years ago
5 years ago

People

(Reporter: stephend, Unassigned)

Tracking

unspecified
2012Q3
x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

Created attachment 481423 [details]
Screenshot of layout in IE 7

The Army of Awesome page looks pretty bad and doesn't fully work, I don't think, in IE 7.

We should fix that, given that we have high support for IE 6-8 on SUMO and Mozilla.com both.

Craig, any chance you can take a look?
Created attachment 481438 [details] [diff] [review]
CSS fixes for IE

This patch should fix it for IE 6 and 7. It was a combination of floats without widths and auto overflow.
Attachment #481438 - Flags: review?(rrosario)
Comment on attachment 481438 [details] [diff] [review]
CSS fixes for IE

Much better!
Attachment #481438 - Flags: review?(rrosario) → review+
BTW, the styles are much better. JavaScript is still broken, and would require a bit of change to get it working.
Thanks Craig and Ricky!

Any idea how much work would be needed to fix the JavaScript?

James, should this layout fix be attached to a SUMO milestone? Or do we wait until JavaScript is working as well?
(In reply to comment #4)
> James, should this layout fix be attached to a SUMO milestone? Or do we wait
> until JavaScript is working as well?

We're adding another 2.2.x milestone that will be appropriate for this, but if IE7 compatibility is now a requirement then this shouldn't be considered fixed until the JS is working as well.
(In reply to comment #4)
> Any idea how much work would be needed to fix the JavaScript?
The issue is the use of `__defineGetter__` and `__defineSetter__`, which isn't supported by IE (not even IE8). I think these properties can be converted to functions pretty easily, but there are about a dozen cases of them. So, everything would have to be thoroughly tested by hand afterwards to make sure it all still works.
Target Milestone: --- → 2.2.7
Priority: -- → P4
Target Milestone: 2.2.7 → Future
__defineGetter__ and __defineSetter__ are non-standard and deprecated, we shouldn't be using them anyway.
Priority: P4 → --
Target Milestone: Future → 2012Q3
I thought IE7 was an unsupported browser, which means we won't fix bugs for it.
Right, but this affects all versions of IE and webkit browser too, as far as I can tell. We can file a new bug "convert __defineGetter__ and __defineSetter__ to functions" or change the name of this one. Your call, Ricky!
IE7 what?
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.