no tooltips for "title" attribute in sidebar

RESOLVED FIXED in mozilla1.6alpha

Status

P3
normal
RESOLVED FIXED
18 years ago
14 years ago

People

(Reporter: c, Assigned: samir_bugzilla)

Tracking

({polish})

Trunk
mozilla1.6alpha
x86
All
polish

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

18 years ago
In the sidebar no tooltips are shown for HTML elements with "title" attribute.

Example:

<P title="this is a title">test</P>

Comment 1

18 years ago
Why would one want to use "title" in combination with the P tag?
Which HTML elements you do or do not use the `title' attribute for is really 
beside the point ...

The point is that anything you can do with elements in an ordinary Web page, you 
should be able to do with the same elements in a Web-like sidebar panel. And that 
includes tooltips. CCing Blake, who's been doing a lot of this already, and 
Robert, who did the `title' tooltips in the first place.
Should be able to get tooltips in the sidebar
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

18 years ago
spam : changing qa to sujay (New Sidebar QA)
QA Contact: shrir → sujay

Comment 5

18 years ago
This will all be fixed soon when <browser/> lands.  Reassigning to me.
Assignee: matt → blakeross
(Reporter)

Comment 6

18 years ago
*** Bug 80822 has been marked as a duplicate of this bug. ***

Comment 7

18 years ago
win98 too..Changing OS to all..

and adding Kevin to cc..tooltips are very important for sidebar Tabs there is no 
too much space to use.   
OS: Windows NT → All

Comment 8

18 years ago
--> matt
Assignee: blake → matt

Comment 9

18 years ago
Adding Fabricio and Roger, 

this affects Major Sidebar Tab producers.  Sidebar tabs like Fedex and others in
the world are using tooltips. Tooltips in the Sidebar tab is amazing because the
visual area is small.

Comment 10

17 years ago
could you please provide a test case?
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 11

17 years ago
Taking for mozilla0.9.9.
Assignee: matt → sgehani
Keywords: polish
Target Milestone: mozilla1.0 → mozilla0.9.9
(Assignee)

Comment 12

17 years ago
Can someone provide a link to the FedEx tab?
Target Milestone: mozilla0.9.9 → mozilla1.0

Comment 13

17 years ago
The fedex tab is at http://www.fedex.com/us/tracking/?template_type=net6tab

It doesn't seem they use a tooltip there though. Another tab to check tooltips
is the note-it tab, it has an image with a tooltip on the right top side of the
tab: http://livesidebar.com/lsbtabs.html

Comment 14

17 years ago
The FedEx tab is available in the Netbusiness category of the Customize Sidebar
dialogue. The actual URL is http://www.fedex.com/us/tracking/?template_type=net6tab.

Comment 15

17 years ago
Grrr... beaten to it!
(Assignee)

Comment 16

17 years ago
Sidebar triage team: over to Layout for a look.  Nominating for nsbeta1.
Assignee: sgehani → attinasi
Component: Sidebar → Layout
Keywords: nsbeta1
QA Contact: sujay → petersen

Comment 17

17 years ago
-->XP Apps.
Assignee: attinasi → trudelle
Component: Layout → XP Apps
QA Contact: petersen → sairuh

Comment 18

17 years ago
cc karnaze.  Chris: we asked for a look, not a bounce. ;-)  This is web content,
which isn't our area.  Who should get this?

Comment 19

17 years ago
We just have to use FillInHTMLTooltip() in the sidebar, I think.

Comment 20

17 years ago
I would test my patch but attempts at getting my sidebar to show up in my debug
build are failing.  Samir, any idea?

Comment 22

17 years ago
-> me

uncc'ing karnaze now that we know it's not a layout issue.

samir, can I get an r=?
Assignee: trudelle → blaker
Target Milestone: mozilla1.0 → mozilla0.9.9
(Assignee)

Comment 23

17 years ago
Comment on attachment 67861 [details] [diff] [review]
patch

r=sgehani  Cool.  Thanks.
Attachment #67861 - Flags: review+

Comment 24

17 years ago
fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
QA Contact: sairuh → tpreston

Comment 25

17 years ago
reopening; I backed this patch out.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla0.9.9 → mozilla1.0

Comment 26

17 years ago
back to samir for now.
Assignee: blaker → trudelle
Status: REOPENED → NEW

Comment 27

17 years ago
->sidebar
Assignee: trudelle → sgehani
Component: XP Apps → Sidebar
QA Contact: tpreston → sujay
(Assignee)

Updated

17 years ago
Target Milestone: mozilla1.0 → Future

Comment 28

17 years ago
nsbeta1- per ADT triage team
Keywords: nsbeta1 → nsbeta1-

Comment 29

17 years ago
This also affects sidebars at http://twiki.org/ - Internet Explorer's sidebar
does handle tooltips, so unfortunately at the moment the IE version of the TWiki
sidebar is better.

See http://twiki.org/cgi-bin/view/Codev/MozillaSidebar#Get_sidebars_now_ to test
a TWiki sidebar, and view source of
http://twiki.org/cgi-bin/view/Codev/WebSidebar?skin=plain to see the title
attributes.  The IE5 sidebar is at
http://twiki.org/cgi-bin/view/Codev/InternetExplorerSidebar if you're interested.

A possibly related issue is that the visited links don't change colour in the
sidebar, though they do work when the sidebar page is viewed in the main window.
(Assignee)

Comment 30

17 years ago
Blake,
I thought removing the class="iframe-panel" fixed this.  I don't see the
titletips on a current mozilla trunk build in either skin (Linux; haven't tried
Win32).  Any ideas?

Comment 31

17 years ago
Just switching to <browser> won't fix this because the tooltip behavior isn't
yet encapsulated into <browser>. It should be, later on (it's not a hard fix at
all).

Comment 32

16 years ago
This is also quite important for the sidebar I created for my counter service
(See http://textcounter.org/admin/sidebar.php?id=8 for a demo), I would really
appreciate a fix.

Comment 33

16 years ago
*** Bug 180421 has been marked as a duplicate of this bug. ***

Comment 34

16 years ago
Hi, I filed bug #100421, which was a duplicate of this one but had the wrong 
URL for the testcase.

I have upgraded to the latest win32 talkback release (Mozilla/5.0 (Windows; U; 
Windows NT 5.0; en-US; rv:1.2a) Gecko/20020910) and still sidebar tooltips are 
not working.

See bug #100421 but use the following url instead of the one noted:

http://www.codemain.com/tabs/freshmeat_tab_codemain.php

Comment 35

16 years ago
My bad.  The strikeout made the bug ID look like 100421, but it is #180421.
Created attachment 110941 [details] [diff] [review]
Updated for bitrot
Attachment #67861 - Attachment is obsolete: true

Updated

16 years ago
Attachment #110941 - Flags: superreview?(jaggernaut)
Attachment #110941 - Flags: review?(sgehani)
Created attachment 110945 [details] [diff] [review]
Fixed patch

The original patch didn't work in the first place,
the sidebar wouldn't have hidden properly.
Attachment #110941 - Attachment is obsolete: true

Updated

16 years ago
Attachment #110945 - Flags: superreview?(jaggernaut)
Attachment #110945 - Flags: review?(sgehani)

Updated

16 years ago
Attachment #110941 - Flags: superreview?(jaggernaut)
Attachment #110941 - Flags: review?(sgehani)
Comment on attachment 110945 [details] [diff] [review]
Fixed patch

sr=jag
Attachment #110945 - Flags: superreview?(jaggernaut) → superreview+

Comment 39

16 years ago
While testing the http://www.codemain.com/tabs/freshmeat_tab_codemain.php I've
found out that the tooltips are not shown even in the browser. I am using
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130
Comment on attachment 110945 [details] [diff] [review]
Fixed patch

Note: some nearby lines have changed so you might have to manually apply the
patch.
Attachment #110945 - Flags: review?(sgehani) → review?(shliang)

Comment 41

16 years ago
Can someone please confirm #39 - no tooltips for title tags in regular page with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130?

Comment 42

16 years ago
Can the patch be applied by endusers? I couldn't find the file
"sidebarOverlay.xul" on my hard drive.
related to bug 90642 ?
"Tooltip with explanation is not shown for <abbr> in attachment"
The file sidebarOverlay.xul is stored in comm.jar (a zip archive)
Comment on attachment 110945 [details] [diff] [review]
Fixed patch

Playing musical reviewers.
Attachment #110945 - Flags: review?(shliang) → review?(timeless)

Updated

16 years ago
Attachment #110945 - Flags: review?(timeless) → review+
/me must remember to check these in :-)
Target Milestone: Future → mozilla1.6alpha
Created attachment 131218 [details] [diff] [review]
Updated for bitrot

For completeness, this is the patch as checked in.
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.