Fix privacy mistakes: if more than X recipiens as CC, ask the user if all recipients should indeed see all email adresses

VERIFIED DUPLICATE of bug 271405

Status

Thunderbird
Message Compose Window
--
enhancement
VERIFIED DUPLICATE of bug 271405
7 years ago
7 years ago

People

(Reporter: jan klopper, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.12) Gecko/20100826 Ubuntu/9.04 (jaunty) Shiretoko/3.5.12
Build Identifier: 

We all know the problem in which you quickly send a newsletter or update to 40 unrelated people. And by mistake use the CC option instead of the BCC options when composing a message.

Many organisations use this instead of an actual mailer program to send seperate mails.

If more than a configurable amount of recipients is in the To or CC fields, it would be a good idea to have Thunderbird ask for confirmation that the user indeed whishes all the recipients to be able to see all of the other recipients their adresses.

This would possibly protect the privacy of the recipients.
With new data/privacy breach laws in the UK and Netherlands, this could save some people a lot of legal issues.

Reproducible: Always

Steps to Reproduce:
1.Send a mail to >20 cc recipients
2.Notice you didnlt use the bcc
3.Bang your head on the desk in shame


Expected Results:  
A question asking if you are sure about the large number of cc adresses, asking if they should see each others addresses.
Possibly offering a button to switch to bcc.

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 271405
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.