If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash when clicking website Browse button (File Dialog) (Milestone)

VERIFIED FIXED

Status

Fennec Graveyard
General
--
critical
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: aaronmt, Assigned: blassey)

Tracking

({crash, relnote})

Trunk
ARM
All
crash, relnote

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Mozilla/5.0 (Android; Linux armv7l; rv:2.0b7pre) Gecko/20101006 Firefox/4.0b7pre Fennec/4.0b1

Device: Motorola Milestone (Droid)

STR:

1. www.imgur.com
2. Click the Browse button

ER: File dialog appears
AR: Firefox crashes, brought back to Homescreen
(Reporter)

Comment 1

7 years ago
Naoki, are you able to reproduce on your Droid 2?
Created attachment 481608 [details]
Droid 2 screenshot

I tried this morning from a clean install, but did not get a repro the crash.  However I did get a wierd blue highlight.

I tried from a dirty install (from alpha -> going to google.com -> beta 1 rc 3) and I get a hang with the wierd blue highlight.
(Reporter)

Comment 3

7 years ago
I see the same blue selection before my crash happens. As well, the build was installed cleanly without any upgrade.
OS: Android → All
(Reporter)

Comment 4

7 years ago
This is happening on any site that brings up the file picker. Tinypic, imgur, imageshack, etc.
Summary: Crash at imgur.com when clicking the Browse button (File Dialog) → Crash when clicking website Browse button (File Dialog) (Milestone)
(Reporter)

Comment 5

7 years ago
I am *not* crashing on simplistic pages with nothing but a file input, see bug 605845 (*but* the file picker is not opening as expected).
tracking-fennec: --- → ?
(Reporter)

Comment 6

7 years ago
So with 10/21 nightly, I get "Fennec is not responding" with the new on dialog (using my url example)
I'm seeing the crash on imgur.com when clicking on the "Browse" button. This is not happening on the Vibrant and the Nexus One where the "Choose a File" dialog pops up.
Keywords: relnote
(Assignee)

Updated

7 years ago
Assignee: nobody → blassey.bugs
tracking-fennec: ? → 2.0b3+
can we get a crash report link for this?
(Reporter)

Comment 9

7 years ago
(In reply to comment #8)
> can we get a crash report link for this?

No reporter, crashes straight back to homescreen. Trying it on beta 2, the first time around I get the new file picker. I dismissed it, click Browse again and it crashes to homescreen.
(Reporter)

Comment 10

7 years ago
(In reply to comment #9)
> (In reply to comment #8)
> > can we get a crash report link for this?
> 
> No reporter, crashes straight back to homescreen. Trying it on beta 2, the
> first time around I get the new file picker. I dismissed it, click Browse again
> and it crashes to homescreen.

Strangely enough, I havn't changed my build. Trying this out today, and it's crashing on first tap at imgur.com. I double tap the content area to zoom in, tap the Browse button, and then I'm at my homescreen. No report.
do you still see this crash with a current nightly?
(Reporter)

Comment 12

7 years ago
No it's not crashing 11/08 nightly, but on dismiss and tap again I get a Fennec is not Responding dialog; in which I force close. This is all at imgur.com.

On my simple FP test (http://aaronmt.com/misc/fp.html), no issues whatsoever.
That would be a new bug (imgur.com just seems to be a crappy site in general, real laggy even with good hardware). I'm calling this crash fixed by http://hg.mozilla.org/mozilla-central/rev/847df5a157c9
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Does not crash for me:
Mozilla/5.0 (Android; Linux armv71; rv2.0b8pre) Gecko/20101111 Firefox/4.0b8pre Fennec/4.0b3pre

Comment 15

6 years ago
Can someone having a Motorola Milestone (Droid) verify this?
(Reporter)

Comment 16

6 years ago
(In reply to comment #15)
> Can someone having a Motorola Milestone (Droid) verify this?

Milestone is not supported.
Does not crash on Mozilla/5.0 (Android;Linux armv7l;rv:9.0a1)Gecko/20110912 Firefox/9.0a1 Fennec/9.0a1
Device: HTC Desire and Droid 2
OS: Android 2.2 and 2.3

Based on this results and comment #16 I'm closing the bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.