All users were logged out of Bugzilla on October 13th, 2018

Thunderbird hangs completely when clicking "get mail"

RESOLVED INCOMPLETE

Status

--
critical
RESOLVED INCOMPLETE
8 years ago
4 years ago

People

(Reporter: Lothsahn, Unassigned)

Tracking

({hang, stackwanted})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs stacktrace])

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.9) Gecko/20100915 Thunderbird/3.1.4

The entire Thunderbird user interface hangs for me (goes white, doesn't respond, windows recommends closing the hung program) when I get mail.  This issue is intermittent, but often happens when I click "get mail".  I find that double-clicking "get mail" appears to make it happen more often, but I cannot reliably reproduce the issue by just opening TB and clicking "get mail" a lot.

While it's very difficult to reproduce when I try, Thunderbird completely locks up about 1-2 times per 8 hour workday--so this issue is very annoying.



Reproducible: Couldn't Reproduce

Steps to Reproduce:
1. Open thunderbird
2. Browse emails
3. Double click "get mail"

(Note: I selected "Tried, but couldn't reproduce it" because it happens very rarely)
Actual Results:  
If the problem happens, the entire user interface hangs and goes white, indicating that Windows can't redraw the window.  Then windows suggests that I force close the program because it's not responding.

Expected Results:  
Fetched my mail, not locked up, etc.

I am running with plugin.disable, so there are no plugins.
I am using the default theme.
I am using the "change quote and reply options" extension. (0.6.4.3)

Comment 1

8 years ago
Hi Lothsahn.  Is this a pop account or imap account?

Does this reproduce with:
auto compact disabled - Tools > Options > Advanced > Network and Disk
thunderbird started in safe mode

please obtain a hang stacktrace 
 (substitute thunderbird where you see firefox)
 https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg
 and use !analyze -v -hang  instead of !analyze -v -f

attach results as a FILE to this bug.
Keywords: hang

Comment 2

8 years ago
(In reply to comment #1)
> Hi Lothsahn.  Is this a pop account or imap account?
> 
> Does this reproduce with:
> auto compact disabled - Tools > Options > Advanced > Network and Disk
> thunderbird started in safe mode
  http://support.mozillamessaging.com/bg/kb/Safe+Mode

other things to check before getting log:
* any folders are at or near 4GB?
* does this happen with your antivirus SW disabled?

> please obtain a hang stacktrace 
>  (substitute thunderbird where you see firefox)
>  https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg
>  and use !analyze -v -hang  instead of !analyze -v -f
> 
> attach results as a FILE to this bug.

with short pop3 or imap protocol log please, per https://wiki.mozilla.org/MailNews:Logging
(Reporter)

Comment 3

8 years ago
1) I use imap.
2) The largest folder is Sent, which is 1GB.  The next largest is INBOX at 844MB.  None are within 4GB
3) I'm not allowed to disable my AV, so I'm not sure.
4) I'll work on getting you the requested debug information.
(Reporter)

Comment 4

8 years ago
I'm having trouble getting the 32-bit version of the tools.  The Microsoft web installer always downloads the 64-bit version of the tools, and this is what is linked to from the "howto" page.  I can either install a previous version of the 32-bit tools or use the latest version of the 64-bit tools.

According to the "How to get a stacktrace" page, I should not use 64-bit tools:
"(You'll want the 32-bit version, even if you are using a 64-bit version of Windows)  Then install it, the standard settings in the installation process are fine."

AND

Q: I'm seeing "wow64" on top of each thread, is that ok ?

A: No, you are running a 64 bit version of Windbg and trying to debug a 32 bit version of the mozilla software. Redownload and install the 32 bit version of windbg.


Should I use the older 32-bit tools or is the "how to get a stacktrace" page out of date, and the 64-bit tools are fine?

Comment 5

8 years ago
from someone else who knows "Older versions of windbg are fine."

(In reply to comment #3)
> 3) I'm not allowed to disable my AV, so I'm not sure.

it will speed the diagnosis process if you can at least disable checking of email directories (thunderbird profile) and email firewall ports. doing so should not put you at extra risk. And such settings are generally recommended to be disabled.  The real risk comes if you attempt to *open* an attachment of a message.
(Reporter)

Comment 6

8 years ago
Unfortunately, this is a work computer, and while I am a local admin, I don't have permission to make such changes.  I'm really sorry--I totally understand why you want the AV disabled, but it's completely outside my control...  For the record, the company uses Symantec Antivirus.

I had Thunderbird hang while attempting to download an attachment--it's never hung there before, but I have the hang dump from that time.  The attachment that I was trying to download was a word document, and word never opened.  For reference, I've never had word fail to open on my computer outside Thunderbird.

I will continue to monitor for the thunderbird hangs not involving an attachment that I've been seeing in the past.
(Reporter)

Comment 7

8 years ago
Created attachment 482530 [details]
Thunderbird Hang while downloading word doc.  Word never opened.  Hung for > 8 hours, never recovered.
(Reporter)

Comment 8

8 years ago
It appears that anytime I try to download a word attachment when using the debugger, it hangs with the following message:

ModLoad: 74020000 740bb000   C:\Windows\WinSxS\x86_microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.4927_none_d08a205e442db5b5\MSVCR80.dll
(21a4.2368): Break instruction exception - code 80000003 (first chance)
eax=00000000 ebx=00000000 ecx=347e0000 edx=0009e298 esi=fffffffe edi=77e13ade
eip=77e90995 esp=002ff7d4 ebp=002ff800 iopl=0         nv up ei pl zr na pe nc
cs=0023  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00000246
ntdll!LdrpDoDebuggerBreak+0x2c:
77e90995 cc              int     3
1:028> g


Going to debug->Go allows the application to continue.  So this is definitely not the hang I normally see.
(Reporter)

Comment 9

8 years ago
Created attachment 482706 [details]
Thunderbird Hang while fetching mail, eventually locked up entire user interface

This dump is representative of the hangs that I typically see every day on Thunderbird.  The system was hung attempting to fetch mail from the inbox, but I could navigate to emails and other folders.

Once I navigated to a few emails, however, the entire user interface locked up.  At this point, I got the requested dump information and it should be in the attachment.

It gave me errors about symbols, but I believe I did exactly as requested:
.sympath SRV*c:\symbols*http://symbols.mozilla.org/thunderbird;SRV*c:\symbols*http://msdl.microsoft.com/download/symbols
.symfix+ c:\symbols
.reload /f

Let me know if the dump contains what you need, or if I need to change my procedure in any way.

Thank you SO much for looking into this!
Attachment #482706 - Attachment mime type: application/octet-stream → text/plain
(In reply to comment #9)
> 
> Let me know if the dump contains what you need, or if I need to change my
> procedure in any way.

Yes you stack trace looks complete.
Whiteboard: [has stack trace]

Comment 11

8 years ago
I suspect this is a dup of bug 588698, which is fixed on the trunk. Have you tried trunk Thunderbird builds?

Comment 12

8 years ago
Lothsahn, you can get a trunk build here. suggest you backup your profile, then use the zip version and extract it to a directory such that you do not overwrite your existing thunderbird program directory.  then double click on thunderbird.exe
Whiteboard: [has stack trace] → [has stack trace][needs trunk test]

Comment 13

8 years ago
Lothsahn, can you test to see if this is indeed fixed in the alpha? http://www.mozillamessaging.com/en-US/thunderbird/early_releases/
Depends on: 588698
(Reporter)

Comment 14

8 years ago
Wayne:

I use thunderbird for my work email.  As such, I have concerns about using an "alpha" software against our email server--if it had a bug where emails were deleted, etc, it could cost me and the company major time and effort.

The issue is also intermittent, so I would have to use it for an extended period of time to see if it's resolved.

I'm sorry I can't help more, but when it's in Beta or RC status, I'd be happy to let you know.

Comment 15

8 years ago
this should become available in a future 3.1.x release via bug 618368, which has NOT yet landed on any branches. (and won't be in the next release to ship, which is v3.1.8)
Status: UNCONFIRMED → NEW
Depends on: 618368
Ever confirmed: true
Whiteboard: [has stack trace][needs trunk test] → [has stack trace][needs trunk test][needs v3.1.next test]

Comment 16

7 years ago
Lothsahn, I am surprised you haven't updated the bug.  Is this working for you in version 5 or newer?
Whiteboard: [has stack trace][needs trunk test][needs v3.1.next test] → [closeme 2012-01-11][has stack trace]
(Reporter)

Comment 17

7 years ago
Wayne:

Actually, I forgot I filed this bug... :)

It's better than it was, but it still happens.  I've just gotten trained to close and reopen Thunderbird occasionally. :)  Because it happens less often now, it's annoying, but not quite as bad as before.

I'll try to get you a hang dump the next time it happens.

Have a merry Christmas, Wayne!

Updated

7 years ago
Keywords: stackwanted
Whiteboard: [closeme 2012-01-11][has stack trace] → [closeme 2012-03-11][needs stacktrace]

Comment 18

7 years ago
please reopen after attaching stacktrace
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2012-03-11][needs stacktrace] → [needs stacktrace]
You need to log in before you can comment on or make changes to this bug.