Rendering artifacts when GLES acceleration enabled

RESOLVED DUPLICATE of bug 609195

Status

()

defect
RESOLVED DUPLICATE of bug 609195
9 years ago
9 years ago

People

(Reporter: romaxa, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
With basic GL image rendering  or with optimized EGL Bind surface, we have strange rendering artifacts.

Probably we have bug in common GL code, and need to optimize common GL code for
GLES.
(Reporter)

Comment 1

9 years ago
Posted image screenshot
(Reporter)

Updated

9 years ago
Summary: Rendering artifacts when GL acceleration enabled → Rendering artifacts when GLES acceleration enabled
(Reporter)

Comment 2

9 years ago
I have heard that it could be related to GL_REPEAT/CLAMP_TO_EDGE parameter... and wrong rendering in common GL code... but why then it works fine on GLX backend?
(Reporter)

Comment 3

9 years ago
I'm using this patch:
https://bug597590.bugzilla.mozilla.org/attachment.cgi?id=481514
And starting Qt fennec with
MOZ_ACCELERATED=1 ./fennec -url about:license

...
It would be nice to check on android and confirm that it is common problem for all GLES implementations
(Reporter)

Comment 4

9 years ago
Some comments about this issue:
********************
Based on the screenshots I can think of three possibilities:

1. You are doing copy scrolling and there is a synchronization problem that
somehow causes rows to be duplicated.

2. You are rendering very tall triangles, causing the accuracy of texture
coordinates to drop.

3. The vertical positioning of layers is somehow incorrect so that the full
surface contents are not filled in for every frame, causing things from
previous frames to show through. Note that we don't support EGL_SWAP_BEHAVIOR =
EGL_PRESERVED_SWAP, so a full frame must be rendered every time (until we
enable eglSwapBuffersRegionNOK() at least).


************
not sure, haven't really seen this before :/ is there a clear for the
background for each frame?
********************
(Reporter)

Comment 5

9 years ago
ok, I found that problem appearing when TEXTURE rotation happen
also I asked our graphics people and they said:
**************************
> Not sure but we are using GL_REPEAT mode for texture and basically problem
> happen when we start uploading texture data in top and that supposed to be
> appeared in bottom...
> 
> Do we support GL_REPEATED mode correctly or any specific tricks possible with
> that?

NPOT textures and GL_REPEAT wrap mode are not supported by GLES2.0 spec
**********************

So I applied patch from bug 609195, and now I don't see this artifacts anymore!
Depends on: 609195
(Reporter)

Comment 6

9 years ago
this is not related to remote rendering
Blocks: opengl-mobile
No longer blocks: 598864
So is this a dup of 609195?
(Reporter)

Comment 8

9 years ago
yes, it is dup
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 609195
You need to log in before you can comment on or make changes to this bug.