Update required pixman version to 0.19.2

RESOLVED FIXED in mozilla2.0b8

Status

Firefox Build System
General
RESOLVED FIXED
8 years ago
4 months ago

People

(Reporter: Takanori MATSUURA, Assigned: Takanori MATSUURA)

Tracking

unspecified
mozilla2.0b8

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
Created attachment 481520 [details] [diff] [review]
Update required pixman version to 0.19.2

"pixman_image_get_component_alpha" which is implemented in pixman-0.19 is called by gfx/cairo/cairo/src/cairo-surface.c.

So we need to update required pixman version to 0.19.2 which is the minimum distributed version at http://cairographics.org/releases/.
Attachment #481520 - Flags: review?(vladimir)

Updated

8 years ago
blocking2.0: ? → final+

Updated

8 years ago
Assignee: nobody → t.matsuu
Comment on attachment 481520 [details] [diff] [review]
Update required pixman version to 0.19.2

err.. this is the right thing to do for sure, but having in-tree cairo calling out to system pixman is quite broken!
Attachment #481520 - Flags: review?(vladimir) → review+
(Assignee)

Comment 2

8 years ago
Can I add "checkin-needed"?

Anyway "--enable-system-pixman" does not work before/after the patch will be applied.

However I think we can get more appropriate feed back from developers if the patch is applied.

Comment 3

8 years ago
Wouldn't it make more sense to upgrade straight to 0.19.4? Since it brings the following perf improvements:
- More ARM NEON fast paths [Siarhei Siamashka]
- Faster NEAREST scaling [Siarhei]
- Faster BILINEAR scaling [Soren Sandmann]
- Faster glyph rendering [Soren]

The first three are important for fennec and the last for linux as were leaking a lot of users to chromium because of perf. Fennec & the linux build of Firefox could use all the help it can get ATM in terms of speed.
Distros can choose to use 0.19.4, we will just require that they use 0.19.2 or later.
(Assignee)

Comment 5

8 years ago
(In reply to comment #3)
As Kyle said, distros "can" choose to use 0.19.4.
This bug fixes "minimum required" pixman version.

If mozilla products require new functions or APIs which are implemented after the release of 0.19.2, we have to set minimum required version to 0.19.4.

If pixman-0.19.4 only have performance improvements and bug fixes, we should keep minimum required version to 0.19.2.

As far as I have checked the release announcement of pixman-0.19.4, there is no new functions or APIs.
http://lists.freedesktop.org/archives/pixman/2010-September/000571.html

So I'll add "checkin-needed" with attachment 481520 [details] [diff] [review].
This looks ready to land.
Keywords: checkin-needed
(Assignee)

Updated

8 years ago
Attachment #481520 - Flags: approval2.0?
Comment on attachment 481520 [details] [diff] [review]
Update required pixman version to 0.19.2

This blocks, it doesn't need approval.
Attachment #481520 - Flags: approval2.0?
http://hg.mozilla.org/mozilla-central/rev/81da4980adaa
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [need landing]
Target Milestone: --- → mozilla2.0b8

Updated

4 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.