If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Never show an unresponsive script dialog for chrome scripts

VERIFIED FIXED

Status

Fennec Graveyard
General
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: mfinkle, Assigned: mfinkle)

Tracking

Trunk
x86_64
Linux
Bug Flags:
in-testsuite ?

Details

Attachments

(3 attachments)

Created attachment 481660 [details] [diff] [review]
patch

If chrome scripts become unresponsive, there is nothing we can really do - especially with electrolysis. Nagging the user is absoluting not the right thing to do. If the front-end becomes unresponsive, we need to find out why and fix it.

The unrepsonsive script dialog makes people think something is wrong in the script, when more likely, the device is CPU bound or running out of memory. The problem is usually miles away from the script shown in the dialog.

Short version: disable the dialog.
Attachment #481660 - Flags: review?(mbrubeck)
Attachment #481660 - Flags: review?(mbrubeck) → review+
pushed:
http://hg.mozilla.org/mobile-browser/rev/21dad529ed35
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Flags: in-testsuite?
WFM: No unresponsive script dialog shows.

Mozilla/5.0 (Maemo;Linux armv71; rv:2.0b8pre)Gecko/20101011 Firefox/4.0b8pre Fennec/4.0b2pre
Mozilla/5.0 (Android; Linux armv71; rv2.0b8pre) Gecko/20101011 Firefox/4.0b8pre Fennec/4.0b2pre
Status: RESOLVED → VERIFIED
I still see this
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Created attachment 483328 [details]
Droid 2 Screenshot

Mozilla/5.0 (Android; Linux armv71; rv2.0b8pre) Gecko/20101014 Firefox/4.0b8pre Fennec/4.0b2pre

I ended up seeing this in today's build as well when syncing for the first time:

1. clean install of fennec on android
2. go to preferences
3. use a sync account to login
4. click on the sync now button
Created attachment 483351 [details]
Android Droid 2 Screenshot

Mozilla/5.0 (Android; Linux armv71; rv2.0b8pre) Gecko/20101014 Firefox/4.0b8pre
Fennec/4.0b2pre

Received another Unresponsive Script when :
1. logging into mail.google.com
2. in another tab open to reader.google.com
3. in another tab searched google
4. tried to go back to the awesomepage and highlight words in the awesomebar.
Seen on Maemo GTK :
Mozilla/5.0 (Maemo;Linux armv71; rv:2.0b8pre) Gecko/20101021 Firefox/4.0b8pre Fennec/4.0b2pre

1) long tap on a mailto: link ( http://people.mozilla.com/~nhirata/html_tp/Mailto.html
2) click on share link
3) set aside for a while 5 or so minutes.

Unresponsive script error message appears.
(Assignee)

Updated

7 years ago
Depends on: 606371
(Assignee)

Updated

7 years ago
Duplicate of this bug: 606431
fixed by bug 606371
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
WFM:

Verified with all noted steps above:

Mozilla/5.0 (Maemo;Linux armv71; rv:2.0b8pre) Gecko/20101026 Firefox/4.0b8pre Fennec/4.0b2pre
Mozilla/5.0 (Android; Linux armv71; rv2.0b8pre) Gecko/20101026 Firefox/4.0b8pre Fennec/4.0b2pre
Status: RESOLVED → VERIFIED
bugspam
Assignee: nobody → mark.finkle
You need to log in before you can comment on or make changes to this bug.