If I leave Fennec's "Confirm Close" dialog unattended, an "Unresponsive Script" dialog corrupts it & keeps Fennec from ever quitting

VERIFIED FIXED

Status

VERIFIED FIXED
8 years ago
5 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Trunk
ARM
Maemo

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
This is on an n900 (maemo), btw.  I'm running today's Fennec 4.0b2pre nightly from the repository:
http://ftp.mozilla.org/pub/mozilla.org/mobile/repos/trunk_en-US/trunk_en-US_nightly.install

STEPS TO REPRODUCE:
 1. Open 2 tabs in Fennec.  (They can both be about:blank)
 2. Click the "x" in upper-right to quit.
  --> The "Confirm Close" / "You are about to close 2 tabs" dialog pops up.
 3. Set the phone down and wait for 5 or 10 minutes.
 4. Unlock the phone (slide open keyboard or use slider on side to toggle screen)

EXPECTED RESULTS:
 "Confirm Close" dialog should still be there, the way I left it.

ACTUAL RESULTS:
  A "Warning: Unresponsive Script" dialog has snuck in and "merged" with my Confirm Close script.  I have two foreground buttons visible: "OK | Cancel", not attached to any dialog, and in the background (grayed out) there's another dialog, saying:
>  Warning: Unresponsive script
>  You are about to close 2 tabs. Continue?A script on this page may be busy, or
>  it may have stopped responding. You can stop the script right now, or you can
>  [--can't read because it's covered up by the floating "OK|Cancel" buttons --]
>  [ Continue ] [ Stop Script ]

See attached screenshot.

PROCEEDING FROM THIS POINT:
 - "OK" and "Cancel" are the only things that are clickable
 - When I click either of them, it takes me back to Fennec, and I can browse normally, except **I can no longer quit Fennec**.  The "X" button in the upper-right won't do anything.  Even if I close all extra tabs (so there's only one remaining), the "X" button still doesn't work.
(Reporter)

Comment 1

8 years ago
Created attachment 481674 [details]
screenshot when I pick my phone back up after it's been sitting at "Confirm Close" for 5-10 minutes
(Reporter)

Updated

8 years ago
tracking-fennec: --- → ?
(Reporter)

Updated

8 years ago
Summary: If I leave Fennec's "Confirm Close" dialog unattended, an "Unresponsive Script" dialog interferes with it & keeps Fennec from ever quitting → If I leave Fennec's "Confirm Close" dialog unattended, an "Unresponsive Script" dialog corrupts it & keeps Fennec from ever quitting
(Reporter)

Comment 2

8 years ago
Just confirmed with a fresh Fennec profile, btw.  I only had to wait about 2 minutes -- 5-10 minutes should be a high upper bound for reproducing this.

Aakash, can you reproduce this?
Fennec modal dialog spin an event loop that must not be friendly to the JS script dialog.

In any case, we just landed bug 602670, which disables the slow script dialog. We shouldn't see it anymore for chrome scripts.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Verified:

Mozilla/5.0 (Maemo;Linux armv71; rv:2.0b8pre)Gecko/20101011 Firefox/4.0b8pre Fennec/4.0b2pre
Status: RESOLVED → VERIFIED
(Assignee)

Updated

5 years ago
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.