[Form Assistant] Top of page shown when moving to password field on lastpass.com/mobile

VERIFIED FIXED

Status

Fennec Graveyard
General
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: aakashd, Assigned: mbrubeck)

Tracking

Trunk
ARM
Android

Details

(Whiteboard: [Input], URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Build Id:
Mozilla/5.0 (Android; Linux armv71; rv:2.0b7pre) Gecko/20101007 Namoroka/4.0b7pre Fennec/4.0b2pre

Note: Bug based off of http://input.mozilla.com/en-US/opinion/528221

Steps to Reproduce:
1. Go to lastpass.com/mobile
2. Tap on "Email" field to open up the form assistant.
3. Tap on the down button on the form assistant bar

Actual Results:
The view goes to the top of the page.

Expected Results:
The view goes to the password field.
(Reporter)

Updated

7 years ago
tracking-fennec: --- → ?
This is a zoom/pan fail. The focus _is_ in the password field.
Assignee: nobody → wjohnston
tracking-fennec: ? → 2.0b2+
(Assignee)

Comment 2

7 years ago
I can't reproduce this.  Is it fixed?
(Reporter)

Comment 3

7 years ago
Yeah, this is still happening to me, but with an added step.

Steps to Reproduce:
1. Go to lastpass.com/mobile
2. Tap on "Email" field to open up the form assistant.
3. Tap on the down button on the form assistant bar
4. Type a character into the field
(Assignee)

Updated

7 years ago
Assignee: wjohnston → mbrubeck
Only an Android bug? This seems to be working fine on N900
(Assignee)

Comment 5

7 years ago
(In reply to comment #4)
> Only an Android bug? This seems to be working fine on N900

Yes, I suspect it has to do with the window resize for the Android keyboard.
(Assignee)

Comment 6

7 years ago
Created attachment 483648 [details] [diff] [review]
band-aid

This patch covers up the problem.  It's definitely not a real fix - you can sometimes still see the page flicker to the top briefly, but it immediately redraws at the correct location.

We still need a real fix for this.  (Maybe bug 595233 will fix it.)  But this change is worth taking in its own right.  It restores animation to formhelper scrolling,  and it fixes a related bug where the zoom can go outside the page boundaries and then snap back when it finishes.
Attachment #483648 - Flags: review?(mark.finkle)
Attachment #483648 - Flags: review?(21)
Attachment #483648 - Flags: review?(mark.finkle) → review+
Attachment #483648 - Flags: review?(21) → review+
(Assignee)

Updated

7 years ago
Blocks: 605119
(Assignee)

Comment 7

7 years ago
Pushed the band-aid: http://hg.mozilla.org/mobile-browser/rev/676b16920e85

Filed bug 605119 to make sure we follow up with a real fix.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Steps to Reproduce:
1. Go to lastpass.com/mobile
2. close hardware keyboard; go to landscape mode
3. Tap on "Email" field to open up the form assistant.
4. dismiss the vkb with the back button
5. Tap on the down button on the form assistant bar
6. Type a character into the field
7. dismiss the vkb with the back button

Note:
1. It happens on first landing on the page and these steps are followed.
(Reporter)

Comment 9

7 years ago
verified FIXED on build:
Mozilla/5.0 (android Linux armv7l; rv:2.0b7pre) Gecko/20101029 Firefox/4.0b8pre Fennec/4.0b2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.