Recent cookie changes made them session only

RESOLVED FIXED

Status

()

Core
Networking: Cookies
--
major
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Matheus Kerschbaum, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101007 Firefox/4.0b8pre
Build Identifier: Built from http://hg.mozilla.org/mozilla-central/rev/007411b98478

Regression from either bug 591447, bug 595925, bug 598196 or bug 599799. This is pretty bad and should block beta8.

Reproducible: Always

Steps to Reproduce:
1.Use any build after rev http://hg.mozilla.org/mozilla-central/rev/8835848bbd17
2.Close the browser
3.Go to a site you were logged in.
Actual Results:  
Site asks for login information (corrupt/missing cookies).

Expected Results:  
Cookies should work.
(Reporter)

Updated

7 years ago
blocking2.0: --- → ?
Keywords: regression
Version: unspecified → Trunk

Comment 1

7 years ago
I really don't understand this. All the persistent unit tests we have pass fine, which means cookies are getting written out and read in just fine.

This could be Windows-only; I'll spin up my builds there and test.

For now, I'm going to back everything out.
Status: UNCONFIRMED → RESOLVED
blocking2.0: ? → ---
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 2

7 years ago
Just want to confirm that my cookies were all lost.  I had to delete cookies.sqlite.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101007 Firefox/4.0b8pre - Build ID: 20101007162259

Comment 3

7 years ago
(In reply to comment #2)
> Just want to confirm that my cookies were all lost.  I had to delete
> cookies.sqlite.
> 
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101007
> Firefox/4.0b8pre - Build ID: 20101007162259

btw... after deleting cooklies.sqlite, cookies are working fine again.

Comment 4

7 years ago
Interesting. So this is something migration-related, probably Windows-only, and perhaps due to WAL.

Has anyone seen this on non-Windows?
(In reply to comment #2)
> Just want to confirm that my cookies were all lost.  I had to delete
> cookies.sqlite.
Getting a copy of that file would have been useful.  In the future, don't just delete things, but please move them aside.

Comment 6

7 years ago
Can you also provide exact steps of what you did, while they're in your head?

I'm assuming it was the following:

1) Download & install hourly
2) Start browser
3) Cookies worked fine, still logged into all forums etc
4) Close browser
4) Start browser, cookies are gone.

Is this correct?

Comment 7

7 years ago
All cookies lost after restart Minefield on Linux.
http://hg.mozilla.org/mozilla-central/rev/8835848bbd17
chrome://browser/content/aboutDialog.xul Firefox/4.0b8pre ID:20101007140706

Comment 8

7 years ago
See comment 6?

Comment 9

7 years ago
We definitely want some tests to cover this case, methinks.

Comment 10

7 years ago
(In reply to comment #8)
> See comment 6?
Yes, I did. I checked the following site.
https://bugzilla.mozilla.org/ and http://forums.mozillazine.org/

And you can check stored cookies by following procedure.
5) Alt > Edit > Preferences > Privacy > select "User custom settings for history" > click "Show Cookies..."

Comment 11

7 years ago
After I installed this fix I restarted Fx4.  I immediately noticed that my cookies were not being 'used'.  I then proceeded to go to sites where I want my cookies saved.  I logged in to a few of them that keep my login info in a cookie.

I looked at my cookies in Options and they were there.  However when I got out of Fx and then back in all cookies were lost. The only way I got cookies to 'stick' was to delete cookies.sqlite and fire up Fx again.  Now my cookies 'stick'.

The cookies file was filled with all my cookies when I looked at the database with a program of mine.  However Fx didn't see them after applying this fix.
(Reporter)

Comment 12

7 years ago
(In reply to comment #6)
> Can you also provide exact steps of what you did, while they're in your head?
> 
> I'm assuming it was the following:
> 
> 1) Download & install hourly
> 2) Start browser
> 3) Cookies worked fine, still logged into all forums etc
> 4) Close browser
> 4) Start browser, cookies are gone.
> 
> Is this correct?

Comment 0 was slightly incorrect, as soon as I install a build with the cookie changes they are busted. I still have a broken copy of cookies.sqlite if its needed. I'll see if I can reproduce this with a new copy of cookies.sqlite, and if so get a cookie log.

Comment 13

7 years ago
(In reply to comment #12)
> Comment 0 was slightly incorrect, as soon as I install a build with the cookie
> changes they are busted. I still have a broken copy of cookies.sqlite if its
> needed. I'll see if I can reproduce this with a new copy of cookies.sqlite, and
> if so get a cookie log.

OK, that makes more sense. Thanks!

The broken copy would be useful -- can you email it to me? By "broken" you mean a file created on an older build and then used once with a new build, right? Log probably won't help much.

Comment 14

7 years ago
Why this bug is marked  resolved fixed?

Comment 15

7 years ago
Because the changes got backed out. It's fixed.
You need to log in before you can comment on or make changes to this bug.