If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Restart after add on uninstall does not remember all open tabs

RESOLVED WORKSFORME

Status

()

Firefox
Session Restore
RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: tclarke, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [session-store-testday])

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b6) Gecko/20100101 Firefox/4.0b6
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b6) Gecko/20100101 Firefox/4.0b6

I removed an add on, and clicked on restart firefox.  However, only my home page reappeared, and not the other tabs I had open.  

Reproducible: Didn't try




Was informed that Flagfox wasn't compatible and needed to obtain the latest version.  Prior to installing it I decided it might be better to remove the old version first.  When I removed it I was prompted to restart Firefox, so I did, but only my home page reappeared, not my other open tabs.
What is/was the Startup Option set to in Tools/Options?
Component: General → Session Restore
QA Contact: general → session.restore
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> What is/was the Startup Option set to in Tools/Options?

Show my home page, but I would expect a restart to reopen existing tabs.
Is this happening in the latest nightly (4.0b8pre)?
Severity: minor → normal
Whiteboard: [session-store-testday]
tclarke: Are your preferences set to clear browser history on quit? Can you still reproduce this? If so, then we can dupe this to bug 622379.
Marking as and assuming to be fixed due to a lack of feedback from the reporter.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
I would argue this should be RESOLVED WORKSFORME, not FIXED as there doesn't appear to be a patch we landed to fix this issue directly.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.