Account Manager won't keep "copies and folders" settings

VERIFIED DUPLICATE of bug 41722

Status

P3
major
VERIFIED DUPLICATE of bug 41722
18 years ago
14 years ago

People

(Reporter: gstovall, Assigned: sspitzer)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
This is on the 20001108 build, but it has been a problem for quite a while.

Open mail/news account settings.  Select "copies and folders" entry from the
list.  Make a change to "Place a copy in" field.  Click okay to save the changes.

Changes are valid until Mozilla is exited.  On next execution of mozilla, the
old values are back again in the fields.

This is 100% reproducible, and I can't get around it.

Consequently, email are always being filed in the wrong folder.
I'm not seeing this.  I'm definitely seeing my prefs getting saved when I hit
"ok" in the account settings dialog.

using this command "cat ~/.mozilla/seth/utgb2nh2.slt/prefs.js | grep Sent | grep
id2"


# after I startup:
user_pref("mail.identity.id2.fcc_folder","mailbox://nobody@Local%20Folders/Sent");
# after I hit OK
user_pref("mail.identity.id2.fcc_folder", "imap://sspitzer@nsmail-1/Sent");
# after I exit the application
user_pref("mail.identity.id2.fcc_folder", "imap://sspitzer@nsmail-1/Sent");

gstovall, can you try the same experiment?  your path and id will differ, but
you get the idea.

Updated

18 years ago
QA Contact: esther → nbaca
(Reporter)

Comment 2

18 years ago
Your comments got me to thinking, so I did more checking.  Everything was
happening exactly as I said.  I would change any of the settings, it would
actually change in prefs.js.  Then on next invocation, the instant I would send
a message, the values would change.  I finally determined that they were being
pulled from file user.js and written into prefs.js.  Once I manually made the
changes in user.js, it was fine.

I would gather that this is not the way things should work.  Should user.js be
deleted?
excellent!

what we have here is a duplicate of
http://bugzilla.mozilla.org/show_bug.cgi?id=41722

the short answer:  delete your user.js file

for details, see #41722

*** This bug has been marked as a duplicate of 41722 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
Verified Duplicate.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.